Bug #19147

Handle issues with loading execution_plan

Added by Ivan Necas 3 months ago. Updated 26 days ago.

Status:Closed
Priority:Normal
Assigned To:Ivan Necas
Category:Foreman plugin
Target version:Foreman - Team Ivan Iteration 13
Difficulty: Bugzilla link:1438601
Found in release: Pull request:https://github.com/theforeman/foreman-tasks/pull/246
Story points-
Velocity based estimate-
Releaseforeman-tasks-0.9.2Release relationshipAuto

Description

There are various reasons that can cause the execution plan for a task not being available. We should still try
to not fail completely at those situations and try to show at least the data we have available in foreman_tasks_tasks table.

How to reproduce:

Follow http://projects.theforeman.org/issues/19146 for reproducer steps and go to the tasks details pages after doing so.

Expected results: the tasks page is still showing at least some data, not failing completely.

Current results: the tasks page is broken, returning 500 status code


Related issues

Related to foreman-tasks - Bug #19146: World invalidation can fail, when execution plans are inv... Closed 11/02/2016

Associated revisions

Revision 8b86a77e
Added by Ivan Necas 3 months ago

Fixes #19147 - handle situations when the plan is not available

There are various reasons that can cause the execution plan for a task
not being available. We should still try to not fail completely at those
situations and try to show at least the data we have available in
foreman_tasks_tasks table.

This changes also support corresponding changes in https://github.com/Dynflow/dynflow/pull/227

History

#1 Updated by Ivan Necas 3 months ago

  • Related to Bug #19146: World invalidation can fail, when execution plans are invalid added

#2 Updated by Ivan Necas 3 months ago

  • Description updated (diff)

#3 Updated by The Foreman Bot 3 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman-tasks/pull/246 added

#4 Updated by Ivan Necas 3 months ago

  • Bugzilla link set to 1438601

#5 Updated by Ivan Necas 3 months ago

  • Target version set to Team Ivan Iteration 13

#6 Updated by Adam Ruzicka 3 months ago

  • Status changed from Ready For Testing to Closed

Closing since github PR got merged.

#7 Updated by Ivan Necas 3 months ago

  • Category set to Foreman plugin
  • Release set to foreman-tasks-0.9.2

Also available in: Atom PDF