Refactor #19295

Use new proxy API for getting information from DHCP

Added by Marek Hulán about 1 year ago. Updated 6 months ago.

Status:Closed
Priority:Normal
Assigned To:Marek Hulán
Category:DHCP
Target version:-
Difficulty: Bugzilla link:
Found in release: Pull request:https://github.com/theforeman/foreman/pull/4462
Story points-
Velocity based estimate-
Release1.16.0Release relationshipAuto

Description

The DHCP API was deprecated in proxy 1.15 as part of #17856


Related issues

Related to Smart Proxy - Feature #17856: SmartProxy should support multiple dhcp reservations for ... Closed 12/27/2016
Related to Foreman - Bug #19321: Unable to delete a host due to DHCP orchestration failure... New 04/19/2017
Related to Foreman - Bug #22925: REGRESSION: foreman fails to delete a host when getting a... Duplicate 03/18/2018

Associated revisions

Revision bf2c7da5
Added by Marek Hulán about 1 year ago

Fixes #19295 - use new DHCP API

History

#1 Updated by Marek Hulán about 1 year ago

  • Related to Feature #17856: SmartProxy should support multiple dhcp reservations for the same ip address added

#2 Updated by The Foreman Bot about 1 year ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/4462 added

#3 Updated by Anonymous about 1 year ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Dominic Cleal about 1 year ago

  • Related to Bug #19321: Unable to delete a host due to DHCP orchestration failure with older smart proxy added

#5 Updated by Marek Hulán 6 months ago

  • Release set to 1.16.0

#6 Updated by Ohad Levy about 1 month ago

  • Related to Bug #22925: REGRESSION: foreman fails to delete a host when getting a 404 from a proxy added

Also available in: Atom PDF