Refactor #19512

update to node 6.10 as minimum node.js version

Added by Michael Moll 9 months ago. Updated 7 months ago.

Status:Closed
Priority:Normal
Assigned To:Michael Moll
Category:JavaScript stack
Target version:-
Difficulty: Bugzilla link:
Found in release: Pull request:https://github.com/theforeman/foreman/pull/4525, https://github.com/theforeman/foreman-packaging/pull/1690, https://github.com/theforeman/foreman/pull/4608, https://github.com/theforeman/foreman-packaging/pull/1691
Story points-
Velocity based estimate-
Release1.16.0Release relationshipAuto

Description

EPEL is bringing node 6.10.1, Debian/Ubuntu can use nodesource repositories.


Related issues

Related to Foreman - Bug #20232: npm install fails Closed 07/06/2017

Associated revisions

Revision 5aeae200
Added by Michael Moll 9 months ago

Refs #19512 - use nodejs 6.10 for EL7 tests

Revision 12760897
Added by Michael Moll 7 months ago

Refs #19512 - update minimum nodejs version

Revision 323fbf78
Added by Michael Moll 7 months ago

Refs #19512 - update nodejs versions

Revision 0cb223bd
Added by Michael Moll 7 months ago

Refs #19512 - update minimum nodejs version

History

#1 Updated by Michael Moll 9 months ago

This needs to wait until nodesource repos for Debian/stretch are available.

#2 Updated by The Foreman Bot 9 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/4525 added

#3 Updated by Marek Hulán 7 months ago

  • Release set to 1.16.0

#4 Updated by The Foreman Bot 7 months ago

  • Pull request https://github.com/theforeman/foreman-packaging/pull/1690 added

#5 Updated by The Foreman Bot 7 months ago

  • Pull request https://github.com/theforeman/foreman/pull/4608 added

#6 Updated by The Foreman Bot 7 months ago

  • Pull request https://github.com/theforeman/foreman-packaging/pull/1691 added

#7 Updated by Michael Moll 7 months ago

  • Status changed from Ready For Testing to Closed

All done, I guess :)

#8 Updated by Michael Moll 7 months ago

Also available in: Atom PDF