Refactor #19524

Pin roadie-rails for Ruby < 2.2 compatibility

Added by Dominic Cleal about 1 month ago. Updated about 23 hours ago.

Status:Closed
Priority:Normal
Assigned To:Dominic Cleal
Category:Packaging
Target version:-
Difficulty: Bugzilla link:
Found in release: Pull request:https://github.com/theforeman/foreman/pull/4613, https://github.com/theforeman/foreman/pull/4527
Story points-
Velocity based estimate-
Release1.15.1Release relationshipAuto

Description

roadie-rails 1.2.0 dropped support for Ruby 2.1 and older, and since 1.2.1 has the minimum version explicitly set to 2.2.

Gem::InstallError: roadie-rails requires Ruby version >= 2.2.

The gem should be pinned on older versions.


Related issues

Related to Foreman - Tracker #19577: Ruby 2.1 deprecated dependencies New 05/17/2017

Associated revisions

Revision 76dd13f7
Added by Dominic Cleal about 1 month ago

fixes #19524 - pin roadie-rails to 1.1.x on Ruby 2.0-2.1

History

#1 Updated by The Foreman Bot about 1 month ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/4527 added

#2 Updated by Dominic Cleal about 1 month ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Ivan Necas about 1 month ago

#4 Updated by Daniel Lobato Garcia 14 days ago

  • Release set to 1.15.1

#5 Updated by The Foreman Bot about 23 hours ago

  • Pull request https://github.com/theforeman/foreman/pull/4613 added

Also available in: Atom PDF