Feature #19582

Inform user that all Puppet Class sub entities affect saving the whole puppet class

Added by Ori Rabin 3 months ago. Updated 2 months ago.

Status:Closed
Priority:Low
Assigned To:Ori Rabin
Category:Smart Variables
Target version:Team Ivan Iteration 15
Difficulty: Bugzilla link:1379291
Found in release: Pull request:https://github.com/theforeman/foreman/pull/4534
Story points-
Velocity based estimate-
Release1.16.0Release relationshipAuto

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1379291

Steps to Reproduce:
1. Have one Smart Variable with failed validation
2. Try to create or edit any variable from the same Puppet Class from Puppet Class-> Smart Variables page
3.

Actual results:
The puppet class is not saved because of an error in a Smart Variable that was not edited

Expected results:
All entities should be independent from each other

Additional info:

Associated revisions

Revision 9ed5fa04
Added by Ori Rabin 3 months ago

Fixes #19582 - Alert when puppetclass is not saved due to error

History

#1 Updated by Ori Rabin 3 months ago

  • Subject changed from Inform user that all Puppet Class sub entities affect saving the whole puppet class to Inform user that all Puppet Class sub entities affect saving the whole puppet class
  • Status changed from New to Assigned
  • Assigned To set to Ori Rabin
  • Target version set to Team Ivan Iteration 15

#2 Updated by The Foreman Bot 3 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/4534 added

#3 Updated by Ori Rabin 3 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Marek Hulán 2 months ago

  • Release set to 1.16.0

Also available in: Atom PDF