Bug #20248

Exporting list of all hosts into a CSV file won't insert Environment, Hostgroup and Model information

Added by Tomer Brisker 5 months ago. Updated 5 months ago.

Status:Closed
Priority:Normal
Assigned To:Tomer Brisker
Category:Inventory
Target version:Team Marek Iteration 18
Difficulty: Bugzilla link:1468627
Found in release: Pull request:https://github.com/theforeman/foreman/pull/4653
Story points-
Velocity based estimate-
Release1.15.3Release relationshipAuto

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1468627

Description of problem: We were trying to export list of all hosts with its information detailed in table, but the information regarding environment, host group and model won't be inserted into CSV file.

Version-Release number of selected component (if applicable): sat6.3.0 snap5

How reproducible: always

Steps to Reproduce:
1. Create hosts
2. Navigate to Hosts -> All Hosts -> Export
3. Open the CSV file

Actual results:

CSV file include host name, operating system and last report information.

Expected results:

CSV file should include all information(Name, Operating system, Environment, Model, Host group, Last report) present in table.

Additional info:

Associated revisions

Revision c8f5cd53
Added by Tomer Brisker 5 months ago

Fixes #20248, #20327 - Respect context in CSV export

Since CSV export is done using an enumerator which is executed by a
different thread to the one that creates it, we need to manually pass in
the context (user, location, organization) to the enumerator.

Revision b0fec173
Added by Tomer Brisker 4 months ago

Fixes #20248, #20327 - Respect context in CSV export

Since CSV export is done using an enumerator which is executed by a
different thread to the one that creates it, we need to manually pass in
the context (user, location, organization) to the enumerator.

(cherry picked from commit c8f5cd53b3551867e54aedd24116293b0e2312d1)

Revision e1af012f
Added by Tomer Brisker 4 months ago

Fixes #20248, #20327 - Respect context in CSV export

Since CSV export is done using an enumerator which is executed by a
different thread to the one that creates it, we need to manually pass in
the context (user, location, organization) to the enumerator.

(cherry picked from commit c8f5cd53b3551867e54aedd24116293b0e2312d1)

History

#1 Updated by The Foreman Bot 5 months ago

  • Status changed from New to Ready For Testing
  • Assigned To set to Tomer Brisker
  • Pull request https://github.com/theforeman/foreman/pull/4653 added

#2 Updated by Marek Hulán 5 months ago

  • Target version set to Team Marek Iteration 18

#3 Updated by Daniel Lobato Garcia 5 months ago

  • Release set to 1.16.0

#4 Updated by Tomer Brisker 5 months ago

  • Status changed from Ready For Testing to Closed

#5 Updated by Tomer Brisker 5 months ago

  • Release changed from 1.16.0 to 1.15.3

Also available in: Atom PDF