Bug #20418

Set proper taxonomy scope when importing puppet classes

Added by Ondřej Pražák 6 months ago. Updated 2 months ago.

Status:Closed
Priority:Normal
Assigned To:Ondřej Pražák
Category:Organizations and Locations
Target version:-
Difficulty: Bugzilla link:1350159
Found in release: Pull request:https://github.com/theforeman/foreman/pull/4699
Story points-
Velocity based estimate-
Release1.16.0Release relationshipAuto

Description

User should import puppet classes only to environments that are in his organizations. The previous attempts to fix this do not cover all the cases. Environments have unique name and some workflows trigger the 'Name already taken' validation error.

Steps to reproduce:
1) create 2 organizations, A and B
2) create a_user, give him Manager role and assign him only to A org
3) import some_puppet_env with a couple of classes only into org B
4) switch to a_user, try to import all environments from the same proxy as in previous step
5) observe the error

When importing environments in step 4, some_puppet_env is marked for creation because it was not found in org A, but it already exists in B.


Related issues

Related to Foreman - Bug #17463: Importing classes for a new org fails when the environmen... Closed 11/23/2016

Associated revisions

Revision a54588a5
Added by Ondřej Pražák 6 months ago

Fixes #20418 - Add taxonomies to newly imported puppet env

History

#1 Updated by Ondřej Pražák 6 months ago

  • Related to Bug #17463: Importing classes for a new org fails when the environment already exist in a different org added

#2 Updated by The Foreman Bot 6 months ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/4699 added

#3 Updated by Ondřej Pražák 6 months ago

  • Bugzilla link set to 1246865

#4 Updated by Anonymous 6 months ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Marek Hulán 6 months ago

  • Release set to 1.16.0

#6 Updated by Daniel Lobato Garcia 4 months ago

  • Category set to Organizations and Locations

#7 Updated by Ondřej Pražák 2 months ago

  • Bugzilla link changed from 1246865 to 1350159

Also available in: Atom PDF