Bug #20890

SSH key validations should return better messages

Added by Tomáš Strachota 14 days ago. Updated 6 days ago.

Status:Closed
Priority:Normal
Assigned To:Shira Maximov
Category:Users
Target version:Team Marek backlog
Difficulty:trivial Bugzilla link:
Found in release: Pull request:https://github.com/theforeman/foreman/pull/4834
Story points-
Velocity based estimate-
Release1.17.0Release relationshipAuto

Description

Creating an ssh key with invalid format results in following two messages:

Key is invalid
Key is invalid

It's caused by ssh_key and format validators:
https://github.com/theforeman/foreman/blob/develop/app/models/ssh_key.rb#L23-L24

The error messages should contain more information:

Key is not a valid public ssh key.
Key must be in OpenSSH public key format.

Associated revisions

Revision 4a96211d
Added by Shira Maximov 6 days ago

Fixes #20890 - changes SSH key validation messages

History

#1 Updated by Shira Maximov 12 days ago

  • Status changed from New to Assigned
  • Assigned To set to Shira Maximov

#2 Updated by The Foreman Bot 11 days ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/4834 added

#3 Updated by Marek Hulán 6 days ago

  • Release set to 1.17.0

#4 Updated by Anonymous 6 days ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF