Bug #22141

Remove smart_proxy_dynflow sinatra/rack dependency

Added by Daniel Lobato Garcia 20 days ago. Updated about 16 hours ago.

Status:Closed
Priority:Normal
Assigned To:Daniel Lobato Garcia
Category:-
Target version:-
Difficulty: Bugzilla link:
Found in release: Pull request:https://github.com/theforeman/smart_proxy_dynflow/pull/42
Story points-
Velocity based estimate-

Description

With these dependencies on the gemspec, running "bundle update" in the smart proxy returns the following error:


Resolving dependencies......
Bundler could not find compatible versions for gem "rack-protection":
  In Gemfile:
    smart_proxy was resolved to 1.17.0.develop, which depends on
      sinatra was resolved to 1.4.6, which depends on
        rack-protection (= 2.0.0)

    smart_proxy_dynflow_core was resolved to 0.1.8, which depends on
      sinatra (~> 1.4) was resolved to 1.4.6, which depends on
        rack-protection (~> 1.4)
Bundler could not find compatible versions for gem "tilt":
  In Gemfile:
    smart_proxy was resolved to 1.17.0.develop, which depends on
      sinatra was resolved to 1.4.0, which depends on
        tilt (~> 2.0)

    smart_proxy_dynflow_core was resolved to 0.1.8, which depends on
      sinatra (~> 1.4) was resolved to 1.4.0, which depends on
        tilt (>= 1.3.4, ~> 1.3)

Associated revisions

Revision 87e0a264
Added by Daniel Lobato Garcia about 16 hours ago

Fixes #22141 - Remove sinatra/rack dependencies

History

#1 Updated by Daniel Lobato Garcia 20 days ago

  • Project changed from Plugins to foreman-tasks

#2 Updated by The Foreman Bot 20 days ago

  • Assigned To set to Daniel Lobato Garcia
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/smart_proxy_dynflow/pull/42 added

#3 Updated by Anonymous about 16 hours ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF