Bug #22711

Webpack uglifier errors out

Added by Michael Moll about 1 month ago. Updated about 1 month ago.

Status:Closed
Priority:High
Assigned To:Ohad Levy
Category:JavaScript stack
Target version:-
Difficulty: Bugzilla link:
Found in release: Pull request:https://github.com/theforeman/foreman/pull/5289, https://github.com/theforeman/foreman/pull/5283, https://github.com/theforeman/foreman/pull/5288, https://github.com/theforeman/foreman/pull/5287
Story points-
Velocity based estimate-
Release1.16.1Release relationshipAuto

Description

Currently webpack:compile fails with:

18:50:21 ERROR in vendor-4138154b37191d0e971d.js from UglifyJs
18:50:21 Unexpected token: name (format_format) [vendor-4138154b37191d0e971d.js:41555,4]

Associated revisions

Revision fdfc5429
Added by Avi Sharvit about 1 month ago

Fixes #22711 - fix uglifyjs-webpack plugin

Revision eefb846c
Added by Michael Moll about 1 month ago

Refs #22711 - add uglifyjs-webpack-plugin to package.json

History

#1 Updated by Michael Moll about 1 month ago

I think 1.16 and 1.17 need to get this, in order to have working builds.

#2 Updated by The Foreman Bot about 1 month ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/5277 added

#3 Updated by Michael Moll about 1 month ago

  • Related to Bug #21857: uglifier 4.x fails to precompile assets added

#4 Updated by Michael Moll about 1 month ago

  • Related to deleted (Bug #21857: uglifier 4.x fails to precompile assets)

#5 Updated by Michael Moll about 1 month ago

  • Priority changed from Normal to High
  • Assigned To deleted (Michael Moll)
  • Status changed from Ready For Testing to New
  • Subject changed from Enable ES6 support for uglifier to Webpack uglifier errors out
  • Pull request deleted (https://github.com/theforeman/foreman/pull/5277)

Setting to high as this is currently blocking tests and package builds. AFAICT now, the root cause is not in the Rails asset pipeline but somewhere in the webpack chain.

#6 Updated by The Foreman Bot about 1 month ago

  • Assigned To set to Ohad Levy
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/5282 added

#7 Updated by The Foreman Bot about 1 month ago

  • Pull request https://github.com/theforeman/foreman/pull/5283 added

#8 Updated by The Foreman Bot about 1 month ago

  • Pull request https://github.com/theforeman/foreman/pull/5287 added

#9 Updated by The Foreman Bot about 1 month ago

  • Pull request https://github.com/theforeman/foreman/pull/5288 added

#10 Updated by Anonymous about 1 month ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

#11 Updated by The Foreman Bot about 1 month ago

  • Pull request https://github.com/theforeman/foreman/pull/5289 added

#12 Updated by Michael Moll about 1 month ago

  • Pull request deleted (https://github.com/theforeman/foreman/pull/5282)

Also available in: Atom PDF