Bug #22839

Planning during delayed jobs and hooks don't clean ActiveRecord connection

Added by Ivan Necas 3 months ago. Updated 24 days ago.

Status:Closed
Priority:Normal
Assigned To:Ivan Necas
Category:Dynflow
Target version:Foreman - Team Ivan Iteration 29
Difficulty: Bugzilla link:
Found in release: Pull request:https://github.com/Dynflow/dynflow/pull/279
Story points-
Velocity based estimate-

Description

This can potentially lead to

2018-03-09T03:30:49  [background] [E] could not obtain a connection from the pool within 5.000 seconds (waited 5.003 seconds); all pooled connections were in use (ActiveRecord::ConnectionTimeoutError)

It's not confirmed, that this actually is causing issues (due to its intermittent nature), but we should
be more defensive every time we execute code inside our runtime, that could cause blocking of connection
from ActiveRecord's connection pool

History

#1 Updated by Ivan Necas 3 months ago

  • Target version set to Team Ivan Iteration 29

#2 Updated by Ivan Necas 3 months ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/Dynflow/dynflow/pull/279 added

#3 Updated by Adam Ruzicka 24 days ago

  • Status changed from Ready For Testing to Closed
  • Category set to Dynflow

Also available in: Atom PDF