Bug #23674

undefined method `include?' for nil:NilClass on selecting some kickstart repos on RH repos page

Added by Partha Aji 28 days ago. Updated 24 days ago.

Status:Closed
Priority:Normal
Assigned To:Partha Aji
Category:Repositories
Target version:Team Brad - Iteration 27
Difficulty: Pull request:https://github.com/Katello/katello/pull/7393
Bugzilla link:1580438 Found in Katello release:
Story points-
Velocity based estimate-
ReleaseKatello 3.7.0Release relationshipAuto

Description

Steps to Reproduce:
1. Navigate to RH Repos page
2. Select content_type = kickstart
3. Try enabling
Red Hat Enterprise Linux Atomic Host (Kickstart)
Red Hat Enterprise Linux Atomic Host Beta (Kickstart)
Red Hat Enterprise Linux 7 Server Beta (Kickstart)
Red Hat Enterprise Linux 7 for IBM Power LE Beta (Kickstart)

Actual results:
The option throws undefined method `include?' for nil:NilClass error

Expected results:
The page should give us list of repos under label and ability to enable those

Additional info:
PFA the error log in comment #1
I am still able to correctly select and enable some kickstarts repos like
Red Hat Enterprise Linux 6 Server (Kickstart)
Red Hat Enterprise Linux 7 Server (Kickstart)

Associated revisions

Revision e98bc550
Added by Partha Aji 24 days ago

Fixes #23674 - Lists no sub KS repos on RH Repos

The new RH Repos page made the assumption that all KS repositories had a
release version set. Turns out that some kickstart repositories do not.
Examples include
Red Hat Enterprise Linux 7 Server Beta (Kickstart)
Red Hat Enterprise Linux 7 for IBM Power LE Beta (Kickstart)

This commit properly handles the case of KS repos that do not have a
release version set.

History

#1 Updated by Partha Aji 28 days ago

  • Bugzilla link set to 1580438

#2 Updated by The Foreman Bot 28 days ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/7393 added

#3 Updated by Jonathon Turel 27 days ago

  • Release set to Katello 3.7.0

#4 Updated by Partha Aji 24 days ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

Also available in: Atom PDF