Bug #23742

Community Job Templates are not assigned to all orgs by default

Added by Daniel Lobato Garcia 20 days ago. Updated 5 days ago.

Status:Closed
Priority:Normal
Assigned To:Marek Hulán
Category:-
Target version:-
Difficulty: Pull request:https://github.com/theforeman/foreman_ansible/pull/177
Bugzilla link:1583481
Story points-
Velocity based estimate-
Releaseforeman_ansible 2.2.0Release relationshipAuto

Description

Description of problem:
When I try to run "Run ansible roles" for apply assigned roles, I get this error message

"ERF42-5962 [Foreman::Exception]: No template mapped to feature Ansible: Run host roles"

Version-Release number of selected component (if applicable):
ansible-2.5.2-1.el7ae.noarch
tfm-rubygem-foreman_ansible-2.1.2.0.1-1.el7sat.noarch
tfm-rubygem-foreman_ansible_core-2.0.2-1.el7sat.noarch
rubygem-smart_proxy_ansible-2.0.2-3.el7sat.noarch
ansiblerole-insights-client-1.5-1.el7sat.noarch

The template has not been assigned to all organizations by default

How reproducible:
100%

Steps to Reproduce:
1. Import role to Sat6.4
2. Assign this role to host
3. Press button "Run ansible roles"

Actual results:
"ERF42-5962 [Foreman::Exception]: No template mapped to feature Ansible: Run host roles"

Expected results:
No error; the role will be apply to host


Related issues

Copied to Foreman Remote Execution - Bug #23891: Community Job Templates are not assigned to all orgs by d... Closed 05/30/2018

Associated revisions

Revision 2399adc2
Added by Marek Hulán 5 days ago

Fixes #23742 - share all templates to all taxonomies

History

#1 Updated by Marek Hulán 7 days ago

  • Copied to Bug #23891: Community Job Templates are not assigned to all orgs by default added

#2 Updated by Marek Hulán 7 days ago

  • Subject changed from Community Job Templates are not assigned to all orgs by default to Community Job Templates are not assigned to all orgs by default

The problem is, we don't put seeded templates under any org/loc. Core does it for provisioning templates and ptables.

#3 Updated by The Foreman Bot 7 days ago

  • Assigned To set to Marek Hulán
  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman_ansible/pull/177 added

#4 Updated by Marek Hulán 5 days ago

  • % Done changed from 0 to 100
  • Status changed from Ready For Testing to Closed

#5 Updated by Marek Hulán 5 days ago

  • Release set to foreman_ansible 2.2.0

Also available in: Atom PDF