Feature #3307

Provide user friendly information when Console tab doesn't work

Added by Dominic Cleal about 4 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assigned To:Stephen Benjamin
Category:VM management
Target version:Sprint 20
Difficulty: Bugzilla link:
Found in release: Pull request:
Story points-
Velocity based estimate-
Release1.5.0Release relationshipAuto

Description

"I feel that we need to provide some type of informative, user friendly notification to the user when the Console tab doesn't work. Right now we display a generic message stating the the connection timed out but if for instance the issue is iptables related, could we provide some type of information as to what are the known issues (see http://projects.theforeman.org/projects/1/wiki/NoVNC)"

(https://bugzilla.redhat.com/show_bug.cgi?id=970665)


Related issues

Duplicated by Foreman - Feature #4339: Provide Troubleshooting Tips on Server Console Page Duplicate 02/13/2014

Associated revisions

Revision b6a429ae
Added by Stephen Benjamin over 3 years ago

fixes #3307 - add troubleshooting to console page

History

#1 Updated by Dominic Cleal about 4 years ago

We could just promote the NoVNC content into the manual and then link straight to the manual content (as per #2763) from the console page.

#2 Updated by Dominic Cleal almost 4 years ago

  • Duplicated by Feature #4339: Provide Troubleshooting Tips on Server Console Page added

#3 Updated by Stephen Benjamin almost 4 years ago

  • Subject changed from Provide user friendly information when Console tab doesn't work due to IPTables rules to Provide user friendly information when Console tab doesn't work

Manual now has VNC troubleshooting steps - http://theforeman.org/manuals/1.4/index.html#7.1NoVNC

#4 Updated by Dominic Cleal almost 4 years ago

  • Status changed from New to Ready For Testing
  • Assigned To set to Stephen Benjamin
  • Target version set to Sprint 20

#5 Updated by Dominic Cleal over 3 years ago

  • Release set to 1.5.0

#6 Updated by Anonymous over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF