Feature #3592

Lazily load compute resource VM details through AJAX for performance

Added by Ewoud Kohl van Wijngaarden about 4 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assigned To:Amos Benari
Category:Compute resources
Target version:Sprint 22
Difficulty: Bugzilla link:
Found in release: Pull request:
Story points-
Velocity based estimate-
Release1.5.0Release relationshipAuto

Description

I recently enabled the vSphere compute resource and my (very unscientific) tests show load times of 926 ms for a bare metal host and 3656 ms for a vSphere host. This is a bad user experience. Lazily loading the VM details tab through AJAX should help the performance here.


Related issues

Related to Foreman - Bug #5389: URL doesn't update correctly after creating a new host Closed 04/22/2014

Associated revisions

Revision 88ed4900
Added by Amos Benari over 3 years ago

fixes #3592 lazy load vm with ajax in host show page.

History

#2 Updated by Dominic Cleal about 4 years ago

  • Status changed from New to Ready For Testing
  • Assigned To set to Amos Benari
  • Target version set to Sprint 16
  • Release set to 1.4.0

#3 Updated by Dominic Cleal about 4 years ago

  • Target version changed from Sprint 16 to Sprint 17

#4 Updated by Dominic Cleal almost 4 years ago

  • Target version changed from Sprint 17 to Sprint 18

#5 Updated by Dmitri Dolguikh almost 4 years ago

  • Target version changed from Sprint 18 to Sprint 19

#6 Updated by Dominic Cleal almost 4 years ago

  • Release deleted (1.4.0)

#7 Updated by Dmitri Dolguikh almost 4 years ago

  • Target version changed from Sprint 19 to Sprint 20

#8 Updated by Dmitri Dolguikh over 3 years ago

  • Target version changed from Sprint 20 to Sprint 21

#9 Updated by Dmitri Dolguikh over 3 years ago

  • Target version changed from Sprint 21 to Sprint 22

#11 Updated by Dominic Cleal over 3 years ago

  • Release set to 1.5.0

#12 Updated by Amos Benari over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#13 Updated by Dominic Cleal over 3 years ago

  • Related to Bug #5389: URL doesn't update correctly after creating a new host added

Also available in: Atom PDF