Bug #4465

%pretrans failure during kickstart

Added by Dan Radez over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assigned To:Jason Montleon
Category:Packaging
Target version:Sprint 21
Difficulty: Bugzilla link:
Found in release: Pull request:
Story points-
Velocity based estimate-
Release1.4.4Release relationshipAuto

Description

I'm trying to kickstart a machine with the foreman rpms already installed.
The install halts citing that foreman has failed to install.
I looked on the system at /mnt/sysimage/root/install.log and saw this error:

error: %pretrans(foreman-1.4.1-2.el6.noarch) scriptlet failed, exit status 127

I've not found any other error messages.


Related issues

Related to Foreman - Bug #5482: Errror when doing an rpm based upgrade from 1.4.1 to 1.5.RC2 Resolved 04/29/2014

Associated revisions

Revision e639a808
Added by Jason Montleon over 3 years ago

Fixes #4465: remove pretrans section of foreman.spec

Revision ca9f8b4d
Added by Jason Montleon over 3 years ago

Fixes #4465: remove pretrans section of foreman.spec

(cherry picked from commit e639a808461a40e1f830d594e970258a52bef516)

History

#1 Updated by Dan Radez over 3 years ago

this link suggests that a shell may not be available at kickstart:
http://fedoraproject.org/wiki/Packaging:Guidelines#Scriptlets
and that %pretrans should be written in Lua:
http://www.rpm.org/wiki/PackagerDocs/RpmLua

#2 Updated by Jason Montleon over 3 years ago

  • Assigned To set to Jason Montleon

#4 Updated by Dominic Cleal over 3 years ago

  • Status changed from New to Ready For Testing
  • Target version set to Sprint 20

#5 Updated by Dmitri Dolguikh over 3 years ago

  • Target version changed from Sprint 20 to Sprint 21

#6 Updated by Dominic Cleal over 3 years ago

  • Release set to 1.5.0

#7 Updated by Jason Montleon over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#8 Updated by Ohad Levy over 3 years ago

  • Release changed from 1.5.0 to 9

please update the 1.4.x packages as well.

#9 Updated by Dominic Cleal over 3 years ago

  • Release changed from 9 to 1.5.0

#10 Updated by Dominic Cleal over 3 years ago

  • Related to Bug #5482: Errror when doing an rpm based upgrade from 1.4.1 to 1.5.RC2 added

#11 Updated by Dominic Cleal over 3 years ago

  • Release changed from 1.5.0 to 1.4.4

Also available in: Atom PDF