Bug #4828

Rake 10.2.0 breaks Ruby 1.8 compatibility

Added by Dominic Cleal over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Urgent
Assigned To:Dominic Cleal
Category:Packaging
Target version:Sprint 21
Difficulty: Bugzilla link:
Found in release: Pull request:
Story points-
Velocity based estimate-
Release1.4.4Release relationshipAuto

Description

Rake 10.2.0 breaks Ruby 1.8 compatibility, it needs pinning.

Gem::InstallError: rake requires Ruby version >= 1.9.
An error occurred while installing rake (10.2.0), and Bundler cannot continue.
Make sure that `gem install rake -v '10.2.0'` succeeds before bundling.

Related issues

Related to Foreman - Tracker #4656: Drop Ruby 1.8 support Closed 03/13/2014

Associated revisions

Revision d59d2728
Added by Dominic Cleal over 3 years ago

fixes #4828 - pin rake for Ruby 1.8 compatibility

Revision b33445ad
Added by Dominic Cleal over 3 years ago

fixes #4828 - pin rake for Ruby 1.8 compatibility

(cherry picked from commit d59d272874a0571fd768b2ff66bf3af1eef57488)

History

#1 Updated by Dominic Cleal over 3 years ago

#2 Updated by Dominic Cleal over 3 years ago

  • Status changed from Assigned to Ready For Testing

#3 Updated by Dominic Cleal over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Dominic Cleal over 3 years ago

  • Release changed from 9 to 1.5.0

#5 Updated by Dominic Cleal over 3 years ago

  • Release changed from 1.5.0 to 1.4.4

Also available in: Atom PDF