Bug #4884

link to gravatar image in a header have "https:///" instead of "https://"

Added by Bryan Kearney over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assigned To:Bryan Kearney
Category:Web Interface
Target version:Sprint 22
Difficulty: Bugzilla link:1003520
Found in release: Pull request:
Story points-
Velocity based estimate-
Release1.5.0Release relationshipAuto

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1003520
Description of problem:
When I log-in using Opera browser, I do not see gravatar image close to my username in upper right corner of the screen. In Firefox, all is OK.

Version-Release number of selected component (if applicable):
SAM 1.3 snapshot #4

How reproducible:
always

Steps to Reproduce:
1. Login to SAM, check your icon at upper right corner.

Actual results:
No icon there - HTML code looks like this:
<img src="https:///secure.gravatar.com/avatar/7ab3e0303edd4e2d550b8905df183d6f?d=mm&s=25" class="gravatar"/>

Expected results:
<img src="https://secure.gravatar.com/avatar/7ab3e0303edd4e2d550b8905df183d6f?d=mm&s=25" class="gravatar"/>

Additional info:
Looks like Firefox handles these three "/", but Opera not.

Associated revisions

Revision ae095693
Added by Bryan Kearney over 3 years ago

Fixes #4884 : remove duplicate slashes from the gravatar url

The issue is that request.protocol returns http:// instead of http. The code assumed no trailing slashes

History

#1 Updated by Dominic Cleal over 3 years ago

  • Category set to Web Interface
  • Status changed from New to Ready For Testing
  • Assigned To set to Bryan Kearney
  • Target version set to Sprint 22

#2 Updated by Anonymous over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Dominic Cleal over 3 years ago

  • Release set to 1.5.0

#4 Updated by Dominic Cleal over 3 years ago

  • Bugzilla link set to https://bugzilla.redhat.com/show_bug.cgi?id=1003520

Also available in: Atom PDF