Bug #5969

deleting of EC2 guests - confusing message

Added by Dominic Cleal almost 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Low
Assigned To:Joseph Magen
Category:VM management
Target version:Sprint 26
Difficulty: Bugzilla link:1102085
Found in release: Pull request:
Story points-
Velocity based estimate-
Release1.6.0Release relationshipAuto

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1102085
Description of problem:
We have a EC2 guest in Sat6.0.
When we delete it, we get a information message "Successfully deleted", but the guest is still contained in EC2 (and in "Compute Resource" > "Virtual Machines"). Amazon deletes guest with the delay (in my case 10 - 60 min).
it means, the message is inaccurate. It would be better something as "The virtual machine will be deleted in few minutes".

Question is it, the difference between the deleting of host ("Hosts" > "All hosts" > delete some of EC2 guests) and deleting of a virtual machine ("Infrastructure" > "Compute resource" > some of EC2 resources > "Virtual Machines" > some of EC2 guests).

First option deletes the host immediately and VM will be automatically deleted in future. In this case, the message is acceptable, we don't see already host in list.

Second option marks VM for deleting and VM will be automatically deleted in future. In this case, the message is confusing, because we see still the VM in list.

Version-Release number of selected component (if applicable):
Satellite-6.0.3-RHEL-6-20140523.0

How reproducible:
100%

Steps to Reproduce:
1. We have got Sat 6.0 with some EC2 guest.
2. Open detail of VM guest "Infrastructure" > "Compute resource" > some of EC2 resources > "Virtual Machines" > some of EC2 guests
3. Click on the "Delete" button.
4. We can see message "Successfully deleted", but VM is still in the list.

Actual results:
"Successfully deleted"

Expected results:
"The virtual machine will be deleted in a few minutes"

Additional info:

Associated revisions

Revision 9d9523c7
Added by Joseph Magen almost 4 years ago

fixes #5969 - improve message when deleting virtual machines to indicate delay

History

#1 Updated by Dominic Cleal almost 4 years ago

  • Category set to VM management

#2 Updated by Joseph Magen almost 4 years ago

  • Status changed from New to Assigned
  • Assigned To set to Joseph Magen
  • Target version set to Sprint 24

#3 Updated by Dmitri Dolguikh almost 4 years ago

  • Target version changed from Sprint 24 to Sprint 25

#4 Updated by Dominic Cleal almost 4 years ago

  • Status changed from Assigned to Ready For Testing

#5 Updated by Dmitri Dolguikh almost 4 years ago

  • Target version changed from Sprint 25 to Sprint 26

#6 Updated by Dominic Cleal almost 4 years ago

  • Release set to 1.6.0

#7 Updated by Joseph Magen almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF