Bug #6177

Setting host build flag via API doesn't clear facts and reports

Added by Dominic Cleal over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assigned To:Dominic Cleal
Category:API
Target version:Sprint 25
Difficulty: Bugzilla link:1114645
Found in release: Pull request:
Story points-
Velocity based estimate-
Release1.5.2Release relationshipAuto

Description

When setting the build attribute on a host to true from the API (or CLI) doesn't clear facts and reports from the hosts. This differs from the UI as it calls Host::Managed#setBuild, while the API is just setting the attribute.

The clear facts/reports might be best moved to the model when the attribute is changed, and the setBuild action on HostsController could just update the attribute.

Associated revisions

Revision aa19255e
Added by Dominic Cleal over 3 years ago

fixes #6177 - clear host facts/reports when build=true set over API

Revision 65b45855
Added by Dominic Cleal over 3 years ago

fixes #6177 - clear host facts/reports when build=true set over API

(cherry picked from commit aa19255e85c1121ae1896466089d286243b814d7)

History

#1 Updated by Dominic Cleal over 3 years ago

  • Status changed from New to Ready For Testing
  • Assigned To set to Dominic Cleal
  • Target version set to Sprint 25

#2 Updated by Dominic Cleal over 3 years ago

  • Release set to 1.5.2

#3 Updated by Dominic Cleal over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Bryan Kearney over 3 years ago

  • Bugzilla link set to 1114645

Also available in: Atom PDF