Bug #6357

user: Firebug raises: ReferenceError: taxonomy_added is not defined while selecting/updating user's location or Org

Added by Dominic Cleal over 3 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assigned To:Daniel Lobato Garcia
Category:Web Interface
Target version:Sprint 26
Difficulty: Bugzilla link:1112346
Found in release: Pull request:
Story points-
Velocity based estimate-
Release1.5.2Release relationshipAuto

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1112346
Description of problem:
I was trying to create new user, but when I selected "default" location from location tab and selected org from org tab, I got following error in Firebug:

ReferenceError: taxonomy_added is not defined

Version-Release number of selected component (if applicable):
sat6 beta snap10 compose2

How reproducible:
always

Steps to Reproduce:
1. create user
2. select/update user's org and location
3.

Actual results:
ReferenceError: taxonomy_added is not defined

Expected results:
no error should be there in firebug while selecting/updating user's location/org

Additional info:


Related issues

Duplicated by Foreman - Bug #6378: javascript error on User form when selecting/de-selecting... Duplicate 06/25/2014

Associated revisions

Revision a729512e
Added by Daniel Lobato Garcia about 3 years ago

Fixes #6357 - ensure JS is loaded so taxonomy_added is defined on user form

History

#1 Updated by Dominic Cleal over 3 years ago

  • Category set to Web Interface
  • Assigned To deleted (Dominic Cleal)

Looks like the javascript is included in the users form, but if you go via the two-pane view (e.g. editing a user) then it won't be loaded as it's not in the application javascript. I wonder if there are other uses of javascript we're missing due to two-pane.

#2 Updated by Dominic Cleal over 3 years ago

  • Status changed from New to Assigned
  • Assigned To set to Daniel Lobato Garcia
  • Target version set to Sprint 25

#3 Updated by Dominic Cleal over 3 years ago

  • Duplicated by Bug #6378: javascript error on User form when selecting/de-selecting locations or organizations added

#4 Updated by Daniel Lobato Garcia over 3 years ago

  • Status changed from Assigned to Ready For Testing

#5 Updated by Dmitri Dolguikh about 3 years ago

  • Target version changed from Sprint 25 to Sprint 26

#6 Updated by Dominic Cleal about 3 years ago

  • Release set to 1.5.2

#7 Updated by Daniel Lobato Garcia about 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF