Bug #6483

oVirt network dropdown not being populated

Added by Joop van de Wege over 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assigned To:Neil Miao
Category:Compute resources - oVirt
Target version:Sprint 26
Difficulty: Bugzilla link:1119899
Found in release: Pull request:https://github.com/theforeman/foreman/pull/1602
Story points-
Velocity based estimate-
Release1.5.2Release relationshipAuto

Description

When using a oVirt CR and creating a new host or a edit compute profiles, the networks dropdown list doesn't populate when the dialog is first rendered. Switching from de pre-selected Default cluster to in my case Test will populate the dropdown list with the correct networks from that cluster. Switching back to Default will fill it with the networks of the Default cluster.
If I don't do this then my VM won't have a NIC on the oVirt side and Foreman will complain about a blanc MAC.
Attached a log of: login, select compute profiles, select small profile, add network, switch to Test cluster, switch back to Default, add storage network to profile.

production.log (28.9 KB) Joop van de Wege, 07/03/2014 07:36 AM


Related issues

Duplicated by Foreman - Bug #6638: RHEVM compute resource missing networks on first attempt ... Duplicate 07/16/2014

Associated revisions

Revision a27196f0
Added by Neil Miao over 3 years ago

Fixes #6483 - oVirt network is properly populated for multiple datacenters

Revision 2bb15995
Added by Neil Miao over 3 years ago

Fixes #6483 - oVirt network is properly populated for multiple datacenters

(cherry picked from commit a27196f08e9976e81449c3812cc0008c5d437c7b)

History

#1 Updated by Joop van de Wege over 3 years ago

Foreman-1.5.1, oVirt-3.4.2, Centos-6.5 (fully upgraded)

#2 Updated by Dominic Cleal over 3 years ago

  • Subject changed from Network dropdown not being populated to oVirt network dropdown not being populated
  • Category set to Compute resources - oVirt

#3 Updated by Joop van de Wege over 3 years ago

Steps to reproduce:
Create new Compute Profile name it 'test2', then edit it and try to add an Interface won't work, change the Template to Blank, save, then edit again, try to add Interface, works now but no networks available, notice Cluster is correct (Default), switch to a different Cluster, notice the network dropdown being populated, switch back and the dropdown is again populated but with the networks from the Default cluster.

Another instance I have @home does only have one Cluster and doesn't have this behaviour.
Our Test instance does have the problem too, also two clusters like production

#4 Updated by Neil Miao over 3 years ago

having the same issue with Foreman 1.5.1 + RHEV 3.3.3.

It seems the NIC is actually added to the compute profile successfully when the CP created, just that the CP editing page couldn't show it up correctly.

When I creating a new host, the NIC dropdown do shows up (with the right Network pre-selected) in the Compute Resource tab, when I do these in order:

1. fill in the host name
2. pick org and location
2. pick the rhev/ovirt compute resource (CR) (wait for the spinning circle disappear)
3. pick the compute profiles (CP) (wait for the spinning circle disappear)

This all good, however, if I create a host group (HG) and attach a CP to this HG, the Network dropdown is empty when creating a host with these steps:

1. fill in name
2. pick org and location
3. pick the host group (which draws in the compute profile automatically)
4. pick the compute resource

#6 Updated by Ori Rabin over 3 years ago

  • Duplicated by Bug #6638: RHEVM compute resource missing networks on first attempt at new host added

#7 Updated by Dominic Cleal over 3 years ago

  • Status changed from New to Ready For Testing
  • Target version set to Sprint 26
  • Pull request https://github.com/theforeman/foreman/pull/1602 added

#8 Updated by Dominic Cleal over 3 years ago

  • Assigned To set to Neil Miao

#9 Updated by Dominic Cleal over 3 years ago

  • Release set to 1.5.2

#10 Updated by Neil Miao over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#11 Updated by Bryan Kearney over 3 years ago

  • Bugzilla link set to 1119899

#12 Updated by Yama Kasi almost 3 years ago

I see this happening on 1.6.1 - 1.6.3 also.

Adding the same Resource again doesn't add the new networks also.

Any idea how to fix/check ?

#13 Updated by Joop van de Wege almost 3 years ago

I just checked but I can't reproduce it anymore. I'm currently on Foreman-1.6.3 el6 and oVirt-3.4.2, el6 too.

Also available in: Atom PDF