Bug #6533

rest-client 1.7.0 dropped Ruby 1.8 support

Added by Dominic Cleal about 3 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assigned To:Daniel Lobato Garcia
Category:Packaging
Target version:Sprint 26
Difficulty: Bugzilla link:1117840
Found in release: Pull request:
Story points-
Velocity based estimate-
Release1.5.2Release relationshipAuto

Description

rest-client 1.7.0 has dropped Ruby 1.8 support, it needs pinning.

Gem::InstallError: rest-client requires Ruby version >= 1.9.2.


Related issues

Related to Foreman - Tracker #4656: Drop Ruby 1.8 support Closed 03/13/2014

Associated revisions

Revision 5dd7da2c
Added by Daniel Lobato Garcia about 3 years ago

Fixes #6533 - rest-client 1.7.0 dropped Ruby 1.8 support

History

#1 Updated by Dominic Cleal about 3 years ago

#2 Updated by Daniel Lobato Garcia about 3 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

#3 Updated by Bryan Kearney about 3 years ago

  • Bugzilla link set to 1117840

#4 Updated by Felix Barbeira about 3 years ago

The "1.5-stable" branch it's also affected. It looks like your commit it's only applied on "develop" branch. Maybe a cherry commit could be good.

#5 Updated by Dominic Cleal about 3 years ago

Yep, it'll be cherry picked soon when we start prepping for 1.5.2. Thanks!

Also available in: Atom PDF