Bug #6693

UI shouldn't switch to other tab while creating OS parameters with same name or with blank name/values

Added by Ori Rabin over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assigned To:Ori Rabin
Category:Web Interface
Target version:Sprint 27
Difficulty: Bugzilla link:1120663
Found in release: Pull request:https://github.com/theforeman/foreman/pull/1611
Story points-
Velocity based estimate-
Release1.6.0Release relationshipAuto

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1120663
Description of problem:
I added OS parameter with blank name/value and UI raises error on submit but as soon as I submit the form, UI switched to main(Operating System) tab. It should stay on same 'Parameters' tab since error is raised under it.

Version-Release number of selected component (if applicable):
sat6 GA snap0

How reproducible:
always

Steps to Reproduce:
1. create OS with parameters name/value as blank
2. submit it
3.

Actual results:
when you submit the form with blank name/value for OS parameters, neither the form was submitted nor you will see any error. Actually error raised but it displays only under 'Parameters' tab. Also, on submit the form, UI quickly switches from 'parameters' tab to 'operating system' tab

Expected results:
Since UI raised error so, It should stay on same page/tab where error was raised.

Additional info:


Related issues

Related to Foreman - Bug #6695: Adding two OS parameters with same name doesn't raise any... Closed 07/20/2014

Associated revisions

Revision 2b5f9c11
Added by Ori Rabin over 3 years ago

Fixes #6693 - set parameters tab to error state and focus when validation fails

History

#1 Updated by Dominic Cleal over 3 years ago

  • Category set to Web Interface

#2 Updated by Dominic Cleal over 3 years ago

  • Related to Bug #6695: Adding two OS parameters with same name doesn't raise any error when values are different added

#3 Updated by The Foreman Bot over 3 years ago

  • Status changed from New to Ready For Testing
  • Target version set to Sprint 26
  • Pull request https://github.com/theforeman/foreman/pull/1611 added

#4 Updated by Dmitri Dolguikh over 3 years ago

  • Target version changed from Sprint 26 to Sprint 27

#5 Updated by Dominic Cleal over 3 years ago

  • Release set to 1.6.0

#6 Updated by Ori Rabin over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF