Bug #6763

Both locations and organizations shown in search autocomplete

Added by Dominic Cleal over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assigned To:Tomer Brisker
Category:Search
Target version:Sprint 28
Difficulty: Bugzilla link:1122828
Found in release: Pull request:https://github.com/theforeman/foreman/pull/1702
Story points-
Velocity based estimate-
Release1.6.1Release relationshipAuto

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1122828
Description of problem:
The search autocompletion on the organisation and location list pages shows both orgs & locs no matter which page you're on.

Version-Release number of selected component (if applicable):
6.0.3

How reproducible:
Always

Steps to Reproduce:
1. View the organisations page
2. Type "name = " into search

Actual results:
Lists both locations and organisations

Expected results:
Only organisations

Additional info:
Vice-versa on locations page.

Associated revisions

Revision 26ee3b1e
Added by Tomer Brisker over 3 years ago

Fixes #6763 - Correctly choose autocomplete search scope for taxonomies depenant on controller

Revision 54e19b73
Added by Tomer Brisker over 3 years ago

Fixes #6763 - Correctly choose autocomplete search scope for taxonomies depenant on controller

(cherry picked from commit 26ee3b1e4f526a3c3975a3640e868dda205b5850)

History

#1 Updated by Dominic Cleal over 3 years ago

  • Category set to Search

#2 Updated by Tomer Brisker over 3 years ago

  • Status changed from New to Assigned

#3 Updated by Tomer Brisker over 3 years ago

  • Assigned To set to Tomer Brisker

This is caused by scoped search mistakenly setting {Organization, Location}.scoped_search_definition.klass to Taxonomy instead of the relevant class.

#4 Updated by The Foreman Bot over 3 years ago

  • Status changed from Assigned to Ready For Testing
  • Target version set to Sprint 28
  • Pull request https://github.com/theforeman/foreman/pull/1702 added

#5 Updated by Dominic Cleal over 3 years ago

  • Release set to 1.6.1

#6 Updated by Anonymous over 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF