Bug #8238

API doc for "Repositories" is incomplete

Added by Bryan Kearney about 3 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assigned To:Bryan Kearney
Category:API
Target version:Sprint 40
Difficulty: Pull request:https://github.com/Katello/katello/pull/4792
Bugzilla link:1120280
Story points-
Velocity based estimate-
ReleaseKatello 2.1Release relationshipAuto

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1120280
Description of problem:
API doc should list "content_type" POST argument as being required. It is listed as being optional.

Version-Release number of selected component (if applicable):
  • apr-util-ldap-1.3.9-3.el6_0.1.x86_64
  • candlepin-0.9.19-1.el6_5.noarch
  • candlepin-scl-1-5.el6_4.noarch
  • candlepin-scl-quartz-2.1.5-5.el6_4.noarch
  • candlepin-scl-rhino-1.7R3-1.el6_4.noarch
  • candlepin-scl-runtime-1-5.el6_4.noarch
  • candlepin-selinux-0.9.19-1.el6_5.noarch
  • candlepin-tomcat6-0.9.19-1.el6_5.noarch
  • elasticsearch-0.90.10-4.el6sat.noarch
  • foreman-1.6.0.21-1.el6sat.noarch
  • foreman-compute-1.6.0.21-1.el6sat.noarch
  • foreman-gce-1.6.0.21-1.el6sat.noarch
  • foreman-libvirt-1.6.0.21-1.el6sat.noarch
  • foreman-ovirt-1.6.0.21-1.el6sat.noarch
  • foreman-postgresql-1.6.0.21-1.el6sat.noarch
  • foreman-proxy-1.6.0.9-1.el6sat.noarch
  • foreman-selinux-1.6.0-5.el6sat.noarch
  • foreman-vmware-1.6.0.21-1.el6sat.noarch
  • katello-1.5.0-26.el6sat.noarch
  • katello-ca-1.0-1.noarch
  • katello-certs-tools-1.5.5-1.el6sat.noarch
  • katello-installer-0.0.53-1.el6sat.noarch
  • openldap-2.4.23-31.el6.x86_64
  • pulp-katello-0.3-3.el6sat.noarch
  • pulp-nodes-common-2.4.0-0.23.beta.el6sat.noarch
  • pulp-nodes-parent-2.4.0-0.23.beta.el6sat.noarch
  • pulp-puppet-plugins-2.4.0-0.23.beta.el6sat.noarch
  • pulp-puppet-tools-2.4.0-0.23.beta.el6sat.noarch
  • pulp-rpm-plugins-2.4.0-0.23.beta.el6sat.noarch
  • pulp-selinux-2.4.0-0.23.beta.el6sat.noarch
  • pulp-server-2.4.0-0.23.beta.el6sat.noarch
  • python-ldap-2.3.10-1.el6.x86_64
  • ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
  • ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch

How reproducible:
100%

Steps to Reproduce:
1. Go to http://qetello02.usersys.redhat.com/apidoc/v2/repositories
2. Click on "POST /katello/api/repositories"
3. Read documentation

Actual results:
"content_type" is listed as optional.

Expected results:
"content_type" is listed as required.

Additional info:
A representative JSON error message one might receive if one attempts to create a repository without specifying a content type is as follows:

{u'content_type': [u'Please select content type from one of the following: yum, file, puppet']}

Associated revisions

Revision bcc6b15d
Added by Bryan Kearney about 3 years ago

Fixes #8238 : Mark content_type parameter as required, since it is for POSTS

Revision 1ab36d42
Added by Bryan Kearney about 3 years ago

Merge pull request #4792 from bkearney/bkearney/8238

Fixes #8238 : Mark content_type parameter as required, since it is for P...

History

#1 Updated by The Foreman Bot about 3 years ago

  • Status changed from New to Ready For Testing
  • Target version set to Sprint 39
  • Pull request https://github.com/Katello/katello/pull/4792 added

#2 Updated by Eric Helms about 3 years ago

  • Release set to Katello 2.1
  • Triaged changed from No to Yes

#3 Updated by Eric Helms about 3 years ago

  • Target version changed from Sprint 39 to Sprint 40

#4 Updated by Bryan Kearney about 3 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF