« Previous - Version 68/77 (diff) - Next » - Current version
Ohad Levy, 12/28/2011 08:25 am

Requirements for the foreman core component

before you start, make sure you have:

  • Puppet >= 0.24-4
  • rake >= 0.84
  • rubygems
  • ruby-sqlite3 (libsqlite3-ruby) if you are going to use sqlite as your database
  • git (if installing from source )
  • ruby-libvirt (epel-repo, only for develop branch)

The installation has been successfully tested on RHEL[5,6], Fedora[13,14], Debian Linux 5.0 (Lenny) and 6.0 (Squeeze) and Ubuntu Linux 10.04, 10.10, and 11.04. For older operating systems you might need additional packages (e.g. sqlite).

It is also known to work on Solaris and Mac.


Foreman Configuration

see also : Smart-Proxy Installation

Future Updates


see Troubleshooting or FAQ