Project

General

Profile

Refactor #10099

pin execjs gem for Ruby 1.9

Added by Anonymous over 7 years ago. Updated about 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Packaging
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

22:45:28 Installing execjs (2.5.1) 
22:45:28 Gem::InstallError: execjs requires Ruby version >= 2.0.0.
22:45:28 An error occurred while installing execjs (2.5.1), and Bundler cannot continue.
22:45:28 Make sure that `gem install execjs -v '2.5.1'` succeeds before bundling.
22:45:28 make: *** [build/foreman] Error 5
22:45:28 dpkg-buildpackage: error: debian/rules build gave error exit status 2

Execjs 2.5.1 requires Ruby 2.0.0 or greater.

I think 1.8 Debian packages need this. Maybe also 1.7.


Related issues

Related to Foreman - Refactor #8884: Drop Ruby 1.9.3 supportClosed2015-01-09

Associated revisions

Revision d88ceee3 (diff)
Added by Michael Moll over 7 years ago

fixes #10099 - pin execjs gem for Ruby 1.9

Revision 294eb61d (diff)
Added by Michael Moll over 7 years ago

fixes #10099 - pin execjs gem for Ruby 1.9

(cherry picked from commit d88ceee3db74051096f5280f92468fe3a2621d90)

History

#1 Updated by Anonymous over 7 years ago

#2 Updated by Dominic Cleal over 7 years ago

  • Legacy Backlogs Release (now unused) set to 40

#3 Updated by Anonymous over 7 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Dominic Cleal over 7 years ago

  • Legacy Backlogs Release (now unused) changed from 40 to 28

1.7-stable is already pinned to < 2.1.0.

Also available in: Atom PDF