Project

General

Profile

Bug #10113

Removing a content view, nothing happens if a content host is using the view

Added by J C over 5 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

I tried to remove a published content view. The view was being used by a content host in a host collection. I was prompted to migrate the affected host, to which I agreed (having selected the default organisation as the new home). The 'next' button stayed depressed, and the page remained the same. I tried again and got the same. I couldn't find the relevant log to explain what was happening. So I removed the content view from the content host and the process worked as expected - I was presented with a pre-action summary page of what would be affected by the removal and once confirmed, the removal was successful.

  1. rpm -q katello
    katello-2.3.0-1.201503310129git07a6e29.el6.noarch

History

#1 Updated by Eric Helms over 5 years ago

  • Legacy Backlogs Release (now unused) changed from 31 to 23
  • Triaged changed from No to Yes

#2 Updated by Andrew Lau over 5 years ago

This also happens when a content view is associated with a hostgroup. It will say it was removing, but in the logs, there's an error saying "Content view is associated with ...." so it won't remove the content view. An error message should be presented to the user instead.

#3 Updated by Eric Helms over 5 years ago

  • Legacy Backlogs Release (now unused) changed from 23 to 31

Looks like you were using a nightly deployment based on the rpm. Further, I tested both these scenarios on 2.2 RC3 and did not encounter the issue. Going to move to 2.3 for now. If you are able to replicate this on 2.2 RC3 or final release I'll move it back. If you do not encounter this anymore at all, please let us know so we can set the issue to the proper status.

#4 Updated by Eric Helms over 5 years ago

  • Legacy Backlogs Release (now unused) changed from 31 to 70

#5 Updated by Justin Sherrill almost 5 years ago

  • Legacy Backlogs Release (now unused) changed from 70 to 86

#6 Updated by Eric Helms over 4 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF