Project

General

Profile

Bug #10318

Author field in metadata.json not parsed

Added by Bryan Kearney about 5 years ago. Updated 9 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Repositories
Target version:
-
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1186377
Description of problem: When a puppet module is uploaded into satellite, the author of the module is not set to the "Author" specified in metadata.json.

Version-Release number of selected component (if applicable): 6.x

How reproducible: Consistent

Steps to Reproduce:
1. Create module and specify "Author" in metadata.json
2. Upload module
3. View module

Actual results: Module author is set to package name, not "Author"

Expected results: The author should be set based on the "Author" field in metadata.json.

Additional info:

History

#1 Updated by Eric Helms about 5 years ago

This sounds more like a Pulp bug since they are the ones that parse the metadata.json

#2 Updated by Eric Helms almost 5 years ago

  • Category set to 89
  • Triaged changed from No to Yes

#3 Updated by Eric Helms over 4 years ago

  • Legacy Backlogs Release (now unused) set to 114

#4 Updated by Bryan Kearney over 4 years ago

  • Category changed from 89 to Web UI

#5 Updated by Bryan Kearney over 4 years ago

  • Category changed from Web UI to Repositories

#6 Updated by John Mitsch 9 months ago

  • Target version deleted (Katello Backlog)
  • Status changed from New to Rejected

Thanks for reporting this issue. This issue was created over 4 years ago and hasn't seen an update in 1 year. We are closing this in an effort to keep a realistic backlog. Please open up a new issue that includes a link to this issue if you feel this still needs to be addressed. We can then triage the new issue and reassess.

Also available in: Atom PDF