Project

General

Profile

Bug #10433

Katello migration assumes all proxies are Katello content capsules

Added by Stephen Benjamin over 7 years ago. Updated over 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Related issues

Is duplicate of Katello - Bug #10426: Error when running 20150423134004_add_content_host_id_to_smart_proxy database migrationClosed2015-05-08

History

#1 Updated by Stephen Benjamin over 7 years ago

  • Category set to 81

It's in db/migrate/20150423134004_add_content_host_id_to_smart_proxy.rb

stbenjam@katello-dev ~/foreman (10286*) $ rake db:migrate                                                                                                                                                                                  :)
API controllers newer than Apipie cache! Run apipie:cache rake task to regenerate cache.
[deprecated] I18n.enforce_available_locales will default to true in the future. If you really want to skip validation of your locale you can set I18n.enforce_available_locales = false to avoid this message.
Workaround for RbVmomi may not work as ComputeResource is already loaded: ComputeResource
==  AddContentHostIdToSmartProxy: migrating ===================================
-- add_column(:smart_proxies, :content_host_id, :integer)
   -> 0.0195s
-- add_foreign_key(:smart_proxies, :katello_systems, {:column=>"content_host_id"})
   -> 0.0205s
rake aborted!
StandardError: An error has occurred, this and all later migrations canceled:

Called id for nil, which would mistakenly be 4 -- if you really wanted the id of nil, use object_id/home/stbenjam/katello/db/migrate/20150423134004_add_content_host_id_to_smart_proxy.rb:15:in `block in change'
/home/stbenjam/katello/db/migrate/20150423134004_add_content_host_id_to_smart_proxy.rb:12:in `each'
/home/stbenjam/katello/db/migrate/20150423134004_add_content_host_id_to_smart_proxy.rb:12:in `change'
/home/stbenjam/.rvm/gems/ruby-1.9.3-p448/gems/activerecord-3.2.21/lib/active_record/migration.rb:407:in `bl

#2 Updated by Stephen Benjamin over 7 years ago

  • Is duplicate of Bug #10426: Error when running 20150423134004_add_content_host_id_to_smart_proxy database migration added

#3 Updated by Stephen Benjamin over 7 years ago

  • Status changed from New to Duplicate

Oops, Walden and Eric beat me to it.

#4 Updated by Eric Helms over 7 years ago

  • Triaged changed from No to Yes

#5 Updated by Eric Helms over 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF