Project

General

Profile

Refactor #10470

Update fog to 1.32.0

Added by Dominic Cleal over 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Compute resources
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Tracker for updating to Fog 1.31.0 (or whatever's after 1.30.0).


Related issues

Related to Foreman - Refactor #10261: Update fog to 1.30.0Closed2015-04-24
Related to Foreman - Refactor #10997: Update fog to 1.33.0Closed2015-07-03
Related to Foreman - Bug #11023: OpenStack wrong tenants url in fog 1.32.0 Closed2015-07-06
Blocks Foreman - Feature #10130: OpenStack Availability Zones should be availableClosed2015-04-14

Associated revisions

Revision d697c426 (diff)
Added by Dominic Cleal about 4 years ago

fixes #10470 - update fog to 1.32.0

Revision 42a9aed0 (diff)
Added by Dominic Cleal about 4 years ago

refs #10470 - use fog 1.32.0

Revision 654c4f4b (diff)
Added by Dominic Cleal about 4 years ago

fixes #10470 - update fog to 1.32.0

(cherry picked from commit d697c426c6c0fd3c264799052e51fd9aa76b370e)

History

#1 Updated by Dominic Cleal over 4 years ago

1.31.0's out, but it depends on fog-core 1.30, which is a bit of a problem to upgrade to at the moment due to our RPM packaging: http://projects.theforeman.org/issues/10261#note-2

#2 Updated by Dominic Cleal over 4 years ago

#3 Updated by Dominic Cleal over 4 years ago

  • Blocks Feature #10130: OpenStack Availability Zones should be available added

#4 Updated by Arnold Bechtoldt over 4 years ago

we need a newer fog version that introduces https://github.com/fog/fog/pull/3523 which makes it possible to deploy windows using vmware "template customization"

#5 Updated by Jason Rist about 4 years ago

Dominic Cleal wrote:

1.31.0's out, but it depends on fog-core 1.30, which is a bit of a problem to upgrade to at the moment due to our RPM packaging: http://projects.theforeman.org/issues/10261#note-2

What do we need to do to get this working? What strings do we need to pull? We need it too for Egon/Tuskar API https://github.com/fusor/egon

#6 Updated by Dominic Cleal about 4 years ago

  • Blocked by Bug #4841: Package Foreman in its own SCL added

#7 Updated by Dominic Cleal about 4 years ago

  • Subject changed from Update fog to 1.31.0 to Update fog to 1.32.0

#8 Updated by Dominic Cleal about 4 years ago

  • Blocked by deleted (Bug #4841: Package Foreman in its own SCL)

#9 Updated by Dominic Cleal about 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Dominic Cleal

Dominic Cleal wrote:

1.31.0's out, but it depends on fog-core 1.30, which is a bit of a problem to upgrade to at the moment due to our RPM packaging: http://projects.theforeman.org/issues/10261#note-2

Seems this was wrong, the json dep is a development dep, not runtime.

#10 Updated by The Foreman Bot about 4 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2514 added
  • Pull request deleted ()

#11 Updated by Dominic Cleal about 4 years ago

  • Legacy Backlogs Release (now unused) set to 35

#12 Updated by Dominic Cleal about 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#13 Updated by Dominic Cleal about 4 years ago

#14 Updated by Dominic Cleal about 4 years ago

  • Related to Bug #11023: OpenStack wrong tenants url in fog 1.32.0 added

Also available in: Atom PDF