Project

General

Profile

Bug #10473

Cannot update lifecycle environment on rhel 66 with GA snap2 installed

Added by Justin Sherrill over 6 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Category:
Hammer
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1217334
Description of problem:
Cannot update lifecycle environment on rhel 66 with GA snap2 installed

Version-Release number of selected component (if applicable):
rpm -qa | grep foreman
ruby193-rubygem-foreman_docker-1.2.0.10-1.el6_6sat.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el6_6sat.noarch
foreman-debug-1.7.2.18-1.el6_6sat.noarch
foreman-vmware-1.7.2.18-1.el6_6sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.6-1.el6_6sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.8-1.el6_6sat.noarch
puppet-foreman_scap_client-0.3.3-8.el6_6sat.noarch
foreman-1.7.2.18-1.el6_6sat.noarch
foreman-libvirt-1.7.2.18-1.el6_6sat.noarch
ruby193-rubygem-foreman_hooks-0.3.7-2.el6_6sat.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.12-1.el6_6sat.noarch
rubygem-hammer_cli_foreman-0.1.4.10-1.el6_6sat.noarch
foreman-postgresql-1.7.2.18-1.el6_6sat.noarch
foreman-selinux-1.7.2.13-1.el6_6sat.noarch
qe-sat6-rhel66.usersys.redhat.com-foreman-proxy-1.0-2.noarch
foreman-compute-1.7.2.18-1.el6_6sat.noarch
foreman-gce-1.7.2.18-1.el6_6sat.noarch
ruby193-rubygem-foreman_discovery-2.0.0.12-1.el6_6sat.noarch
foreman-proxy-1.7.2.4-1.el6_6sat.noarch
qe-sat6-rhel66.usersys.redhat.com-foreman-client-1.0-1.noarch
qe-sat6-rhel66.usersys.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-ovirt-1.7.2.18-1.el6_6sat.noarch
ruby193-rubygem-foreman-redhat_access-0.1.0-1.el6_6sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.4-1.el6_6sat.noarch
ruby193-rubygem-foreman-tasks-0.6.12.4-1.el6_6sat.noarch

How reproducible:
everytime

Steps to Reproduce:
1. LANG=en_US.UTF-8 hammer -v -u admin -p changeme --output=csv lifecycle-environment update --id="281" --organization-id="240" --description="ÝÝÒÕÔÐÌûîÃÁíÂÄÒ"
[ERROR 2015-04-30 03:30:38 Exception] Error: At least one of options --prior, --prior-id is required

See: 'hammer lifecycle-environment update --help'
Could not update environment:
Error: At least one of options --prior, --prior-id is required

See: 'hammer lifecycle-environment update --help'
[ERROR 2015-04-30 03:30:38 Exception]

Clamp::UsageError (At least one of options --prior, --prior-id is required):
/usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.4.9/lib/hammer_cli/./apipie/../abstract.rb:37:in `parse'
/usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:66:in `run'
/usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.4.9/lib/hammer_cli/./apipie/../abstract.rb:23:in `run'
/usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/subcommand/execution.rb:11:in `execute'
/usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:67:in `run'
/usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.4.9/lib/hammer_cli/./apipie/../abstract.rb:23:in `run'
/usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/subcommand/execution.rb:11:in `execute'
/usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:67:in `run'
/usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.4.9/lib/hammer_cli/./apipie/../abstract.rb:23:in `run'
/usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:125:in `run'
/usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.4.9/bin/hammer:108
/usr/bin/hammer:19:in `load'
/usr/bin/hammer:19

2.
3.

Actual results:
the environment is not updated

Expected results:
the environment is updated

Additional info:
foreman-debug attached

Associated revisions

Revision 33aea9c5 (diff)
Added by Justin Sherrill over 6 years ago

fixes #10473 - do not support prior id on environment update

Revision cf21fd50 (diff)
Added by Justin Sherrill over 6 years ago

Refs #10473 - remove prior option from environment update

as its not possible to update it

Revision 56ac3566
Added by Justin Sherrill over 6 years ago

Merge pull request #5221 from jlsherrill/10473

Refs #10473 - remove prior option from environment update

Revision 61a710ff
Added by Justin Sherrill over 6 years ago

Merge pull request #293 from jlsherrill/10473

fixes #10473 - do not support prior id on environment update

History

#1 Updated by The Foreman Bot over 6 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/hammer-cli-katello/pull/293 added
  • Pull request deleted ()

#2 Updated by Justin Sherrill over 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Eric Helms over 6 years ago

  • Legacy Backlogs Release (now unused) set to 31
  • Triaged changed from No to Yes

Also available in: Atom PDF