Project

General

Profile

Bug #10566

Unique interface identifier requirement prevents host from being edited if duplicate identifier exists

Added by Patrick Mulrooney about 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
Network
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Related to #9618.

Before the unique interface identifier validation was introduced we managed to get several hosts with multiple interfaces with the same identifier. Now that we have upgrade to 1.8+ when we attempt to resolve this situation by deleting the duplicate identifiers we are unable to due to the new validation.

This seems like something the validator should check for as it creates a loop. You are unable to resolve the uniqueness requirement, because your interfaces are not unique.


Related issues

Related to Foreman - Bug #9618: User shouldn't be allowed to create an interface with same identifier of any existing oneClosed2015-03-03
Related to Foreman - Bug #11247: IP address is invalid, can't add or remove `.` from identifierResolved2015-07-29
Related to Foreman - Bug #16935: updating a NIC's "Device identifier" if it doesn't already have one fails if the "Device identifier" includes a . or :Closed2016-10-14

Associated revisions

Revision a6b8542a (diff)
Added by Marek Hulán about 4 years ago

Fixes #10566 - allow identifier modifications that do not change interface type

Revision f967d733 (diff)
Added by Marek Hulán about 4 years ago

Fixes #10566 - allow identifier modifications that do not change interface type

(cherry picked from commit a6b8542a0e1a7eb0d71fdd1d328b224669e3010b)

History

#1 Updated by Patrick Mulrooney about 4 years ago

To reproduce...

1. Setup foreman such that a host has multiple interfaces with same identifier
1.5. I believe this can be done in versions prior to 1.8+
2. Upgrade to 1.8+
3. Attempt to remove one of the inter faces from the host.

#2 Updated by Dominic Cleal about 4 years ago

  • Related to Bug #9618: User shouldn't be allowed to create an interface with same identifier of any existing one added

#3 Updated by Dominic Cleal about 4 years ago

  • Legacy Backlogs Release (now unused) set to 56

#4 Updated by Rubén Fernández about 4 years ago

I'm fancing the same issue from fresh installation v1.8.1
I can't modify anything from that host because one interface is duplicated, but it not possible delete any of the duplicate entry.

#5 Updated by The Foreman Bot about 4 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2427 added
  • Pull request deleted ()

#6 Updated by Marek Hulán about 4 years ago

  • Assignee set to Marek Hulán

#7 Updated by Marek Hulán about 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#8 Updated by Dominic Cleal about 4 years ago

  • Related to Bug #11247: IP address is invalid, can't add or remove `.` from identifier added

#9 Updated by Dominic Cleal almost 3 years ago

  • Related to Bug #16935: updating a NIC's "Device identifier" if it doesn't already have one fails if the "Device identifier" includes a . or : added

Also available in: Atom PDF