Project

General

Profile

Bug #10574

pulp-katello plugin depends on qpid

Added by cristian falcas over 6 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Inter Server Sync
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

pulp-katello plugin depends on qpid, but pulp can also use rabbitmq as a broker.

Since I'm not sure that this is the write place to post katello related bugs, please let me know if I should open the issue someplace else.


Related issues

Related to Katello - Bug #11285: Katello 2.3 Repo Sync issueClosed2015-08-04

History

#1 Updated by cristian falcas over 6 years ago

I meant to say pulp-katello rpm. Sorry.

#2 Updated by Eric Helms over 6 years ago

  • Triaged changed from No to Yes

This is the correct place for Katello bugs; however, I am not sure from reading what the issue is? Is this just a missing dependency in the RPM spec?

#3 Updated by cristian falcas over 6 years ago

The problem is that it depends on qpid and it shouldn't. Pulp supports qpid and rabbitmq.

Obviously, we are using rabbitmq.

#4 Updated by Eric Helms over 6 years ago

The problem is that we don't support Rabbitmq officially or provide any way to configure Rabbit for Pulp on the server. I am not even sure if qpid and Rabbit play nice on the same box? I suppose for the disconnected use case we might could relax that restriction, it would, however, be an unsupported use case at present.

#5 Updated by cristian falcas over 6 years ago

We are aware that katello doesn't support rabbitmq, but this is for a separate pulp installation that we want to integrate in katello. We have several pulp installations that run with rabbitmq. The same is for us for the elasticsearch instances.

I don't remember if the official pulp puppet module supports rabbitmq, but we have some patches that we want to push and try to integrate upstream for this.

#6 Updated by Eric Helms over 6 years ago

I think I am with you now, you want to eb able to install the plugin on your own Pulps to have the same functionality that it provides? Looking at the plugin I don't see why it was ever set to require qpid specifically since nothing in it appears to be directly related to the message broker being used.

We are actively working on removing ES from our setup as well.

Side question: you are the person has been contributing to the katello/puppet-pulp?

#7 Updated by cristian falcas over 6 years ago

Yes, the patches where from me.

We rebuilt the pulp-katello rpm without the qpid dependencies and installed it on our pulp server. From our limited tests we didn't find any problems yet with this: repos are created and populated.

#8 Updated by Eric Helms over 6 years ago

  • Legacy Backlogs Release (now unused) set to 55

Awesome - I will put it on my to do list to fix this up.

#9 Updated by Eric Helms over 6 years ago

  • Pull request https://github.com/Katello/pulp-katello-plugins/pull/12 added
  • Pull request deleted ()

Cristian,

Since you have built the package in your test environment, would you mind reviewing the attached pull request as well?

Thanks,
Eric

#10 Updated by Eric Helms over 6 years ago

  • Status changed from New to Closed
  • Legacy Backlogs Release (now unused) changed from 55 to 31

This has been done and released to our nightly repositories. If you need a signed, packaged version of this in the 2.2 repositories let us know and I will include it.

#11 Updated by Stephen Benjamin about 6 years ago

  • Related to Bug #11285: Katello 2.3 Repo Sync issue added

Also available in: Atom PDF