Project

General

Profile

Bug #10599

katello-installer capsule module does not expose dhcp_option_domain dhcp parameter

Added by Eric Helms over 6 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Installer
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1218549
Description of problem:

When installing Satellite with DHCP Capsule, I don't have a way to configure DHCP "option domain-name" in dhcpd.conf. This means it always gets default value from "domain" fact, which is the domain of host on which I run the installer. When I later provision a host from this Satellite the host is always in the same domain as Capsule primary domain even though I provision him in different domain, which results in duplicate host creation since we create a new host if puppet facts have different hostname that is not in DB yet. Also (because of another issue) we import the same IP in the duplicate host making the DB invalid.

Version-Release number of selected component (if applicable):

katello-installer-2.3.6-1.el6_6sat.noarch

How reproducible:

100%

Steps to Reproduce:
1. run katello-installer to setup provisioning capsule with domain example.com
2. configure provisioning and provision a host through PXE and provision it on example.com
3. check fqdn on provisioned host

Actual results:

you see that fqdn contains domain of capsule server

Expected results:

fqdn should contain example.com as a domain

Additional info:

the scenario is also described in related but different Foreman upstream issue http://projects.theforeman.org/issues/10366

Associated revisions

Revision 7821646b (diff)
Added by Eric Helms over 6 years ago

Fixes #10599: Add missing dhcp options.

Revision 7821646b (diff)
Added by Eric Helms over 6 years ago

Fixes #10599: Add missing dhcp options.

Revision e00765a2
Added by Eric D Helms over 6 years ago

Merge pull request #46 from ehelms/fixes-10599

Fixes #10599: Add missing dhcp options.

Revision e00765a2
Added by Eric D Helms over 6 years ago

Merge pull request #46 from ehelms/fixes-10599

Fixes #10599: Add missing dhcp options.

History

#1 Updated by Eric Helms over 6 years ago

  • Legacy Backlogs Release (now unused) set to 31
  • Triaged changed from No to Yes

#2 Updated by Eric Helms about 6 years ago

  • Pull request https://github.com/Katello/katello-installer/pull/235 added
  • Pull request deleted ()

#3 Updated by Eric Helms about 6 years ago

  • Status changed from New to Closed

Also available in: Atom PDF