Project

General

Profile

Bug #10608

'Non-fatal POSTIN scriptlet failure in rpm package' (when installing server cert / subscription-manager)

Added by J C over 6 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Client/Agent
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

CentSOS 5 client...

# yum install --nogpgcheck /path/to/server/cert.rpm
<snip>
error: subscription-manager-1.11.3-11.el5: Header V4 RSA/SHA1 signature:
BAD, key ID d5a88496
   Installing     : katello-ca-consumer-myhostname.mydomain
Non-fatal POSTIN scriptlet failure in rpm package
katello-ca-myhostname.mydomain-1.0-1.noarch
error: %post(katello-ca-consumer-myhostname.mydomain-1.0-1.noarch)
scriptlet failed, exit status 1

# yum install --nogpgcheck subscription-manager
<snip>
Installing:
 subscription-manager                     x86_64                     1.11.3-11.el5                        katello-agent                     1.1 M
<snip>
Transaction Test Succeeded
Running Transaction
error: subscription-manager-1.11.3-11.el5: Header V4 RSA/SHA1 signature: BAD, key ID d5a88496
Installed:
  subscription-manager.x86_64 0:1.11.3-11.el5
Complete!
# rpm -qa --last | head -1
python-uuid-1.30-3.el5                        Fri 22 May 2015 09:56:48 BST

# rpm -v --checksig subscription-manager-1.11.3-11.el5.x86_64.rpm
subscription-manager-1.11.3-11.el5.x86_64.rpm:
    Header V4 RSA/SHA1 signature: BAD, key ID d5a88496
    Header SHA1 digest: OK (347ce92f655257467140bc842d122224f425aaa8)
    V4 RSA/SHA1 signature: BAD, key ID d5a88496
    MD5 digest: OK (2ff9ba31ad09f0524a9d9848e5baaeae)


Should it be V3?

Installed Packages:

candlepin-0.9.45-1.el6.noarch
candlepin-common-1.0.22-1.el6.noarch
candlepin-selinux-0.9.45-1.el6.noarch
candlepin-tomcat6-0.9.45-1.el6.noarch
elasticsearch-0.90.10-7.el6.noarch
katello-2.2.0-5.el6.noarch
katello-certs-tools-2.0.1-1.el6.noarch
katello-common-2.2.0-5.el6.noarch
katello-debug-2.2.0-5.el6.noarch
katello-default-ca-1.0-1.noarch
katello-installer-2.2.0-6.el6.noarch
katello-installer-base-2.2.0-6.el6.noarch
katello-repos-2.2.0-7.el6.noarch
katello-selinux-2.2.1-1.el6.noarch
katello-server-ca-1.0-1.noarch
katello-service-2.2.0-5.el6.noarch
libqpid-dispatch-0.4-4.el6.x86_64
m2crypto-0.21.1.pulp-8.el6.x86_64
mod_wsgi-3.4-2.pulp.el6.x86_64
ptnousvapp100.rnet.dstl.gov.uk-qpid-broker-1.0-1.noarch
ptnousvapp100.rnet.dstl.gov.uk-qpid-client-cert-1.0-1.noarch
ptnousvapp100.rnet.dstl.gov.uk-qpid-router-client-1.0-1.noarch
ptnousvapp100.rnet.dstl.gov.uk-qpid-router-server-1.0-1.noarch
pulp-docker-plugins-0.2.2-1.el6.noarch
pulp-katello-0.4-1.el6.noarch
pulp-nodes-common-2.6.0-1.el6.noarch
pulp-nodes-parent-2.6.0-1.el6.noarch
pulp-puppet-plugins-2.6.0-1.el6.noarch
pulp-puppet-tools-2.6.0-1.el6.noarch
pulp-rpm-plugins-2.6.0-1.el6.noarch
pulp-selinux-2.6.0-1.el6.noarch
pulp-server-2.6.0-1.el6.noarch
python-gofer-qpid-2.5.3-1.el6.noarch
python-isodate-0.5.0-4.pulp.el6.noarch
python-kombu-3.0.24-5.pulp.el6.noarch
python-pulp-bindings-2.6.0-1.el6.noarch
python-pulp-common-2.6.0-1.el6.noarch
python-pulp-docker-common-0.2.2-1.el6.noarch
python-pulp-puppet-common-2.6.0-1.el6.noarch
python-pulp-rpm-common-2.6.0-1.el6.noarch
python-qpid-0.30-7.el6.noarch
python-qpid-qmf-0.30-5.el6.x86_64
python-rhsm-1.8.0-2.pulp.el6.x86_64
qpid-cpp-client-0.30-7.proton.0.9.el6.x86_64
qpid-cpp-client-devel-0.30-7.proton.0.9.el6.x86_64
qpid-cpp-server-0.30-7.proton.0.9.el6.x86_64
qpid-cpp-server-linearstore-0.30-7.proton.0.9.el6.x86_64
qpid-dispatch-router-0.4-4.el6.x86_64
qpid-proton-c-0.9-2.el6.x86_64
qpid-qmf-0.30-5.el6.x86_64
qpid-tools-0.30-4.el6.noarch
ruby193-rubygem-katello-2.2.0-10.el6.noarch
ruby193-rubygem-qpid_messaging-0.30.0-1.el6.x86_64
rubygem-hammer_cli_katello-0.0.13-1.el6.noarch
rubygem-smart_proxy_pulp-1.0.1-1.el6.noarch


Related issues

Related to Katello - Bug #24771: Bad Signatures for EL5 Katello 3.5 client packages Need more information

History

#1 Updated by Eric Helms over 6 years ago

  • Legacy Backlogs Release (now unused) changed from 51 to 55

#2 Updated by J C over 6 years ago

J C wrote:

CentSOS 5 client...

[...]
Should it be V3?

Installed Packages:

candlepin-0.9.45-1.el6.noarch
candlepin-common-1.0.22-1.el6.noarch
candlepin-selinux-0.9.45-1.el6.noarch
candlepin-tomcat6-0.9.45-1.el6.noarch
elasticsearch-0.90.10-7.el6.noarch
katello-2.2.0-5.el6.noarch
katello-certs-tools-2.0.1-1.el6.noarch
katello-common-2.2.0-5.el6.noarch
katello-debug-2.2.0-5.el6.noarch
katello-default-ca-1.0-1.noarch
katello-installer-2.2.0-6.el6.noarch
katello-installer-base-2.2.0-6.el6.noarch
katello-repos-2.2.0-7.el6.noarch
katello-selinux-2.2.1-1.el6.noarch
katello-server-ca-1.0-1.noarch
katello-service-2.2.0-5.el6.noarch
libqpid-dispatch-0.4-4.el6.x86_64
m2crypto-0.21.1.pulp-8.el6.x86_64
mod_wsgi-3.4-2.pulp.el6.x86_64
ptnousvapp100.rnet.dstl.gov.uk-qpid-broker-1.0-1.noarch
ptnousvapp100.rnet.dstl.gov.uk-qpid-client-cert-1.0-1.noarch
ptnousvapp100.rnet.dstl.gov.uk-qpid-router-client-1.0-1.noarch
ptnousvapp100.rnet.dstl.gov.uk-qpid-router-server-1.0-1.noarch
pulp-docker-plugins-0.2.2-1.el6.noarch
pulp-katello-0.4-1.el6.noarch
pulp-nodes-common-2.6.0-1.el6.noarch
pulp-nodes-parent-2.6.0-1.el6.noarch
pulp-puppet-plugins-2.6.0-1.el6.noarch
pulp-puppet-tools-2.6.0-1.el6.noarch
pulp-rpm-plugins-2.6.0-1.el6.noarch
pulp-selinux-2.6.0-1.el6.noarch
pulp-server-2.6.0-1.el6.noarch
python-gofer-qpid-2.5.3-1.el6.noarch
python-isodate-0.5.0-4.pulp.el6.noarch
python-kombu-3.0.24-5.pulp.el6.noarch
python-pulp-bindings-2.6.0-1.el6.noarch
python-pulp-common-2.6.0-1.el6.noarch
python-pulp-docker-common-0.2.2-1.el6.noarch
python-pulp-puppet-common-2.6.0-1.el6.noarch
python-pulp-rpm-common-2.6.0-1.el6.noarch
python-qpid-0.30-7.el6.noarch
python-qpid-qmf-0.30-5.el6.x86_64
python-rhsm-1.8.0-2.pulp.el6.x86_64
qpid-cpp-client-0.30-7.proton.0.9.el6.x86_64
qpid-cpp-client-devel-0.30-7.proton.0.9.el6.x86_64
qpid-cpp-server-0.30-7.proton.0.9.el6.x86_64
qpid-cpp-server-linearstore-0.30-7.proton.0.9.el6.x86_64
qpid-dispatch-router-0.4-4.el6.x86_64
qpid-proton-c-0.9-2.el6.x86_64
qpid-qmf-0.30-5.el6.x86_64
qpid-tools-0.30-4.el6.noarch
ruby193-rubygem-katello-2.2.0-10.el6.noarch
ruby193-rubygem-qpid_messaging-0.30.0-1.el6.x86_64
rubygem-hammer_cli_katello-0.0.13-1.el6.noarch
rubygem-smart_proxy_pulp-1.0.1-1.el6.noarch

Just to add, I'm not able to continue with our deployment of Katello until a solution exists, as we have a lot of CentOS5 clients, so would be grateful if this could be prioritised.

#3 Updated by Eric Helms over 6 years ago

  • Triaged changed from No to Yes

#4 Updated by Eric Helms over 6 years ago

  • Status changed from New to Assigned
  • Assignee set to Eric Helms

I am working on trying to reproduce this issue.

#5 Updated by Eric Helms over 6 years ago

  • Status changed from Assigned to Resolved

The EL5 client repositories have been updated as they were signed incorrectly. Please test them and re-open this issue if you see further issues.

#6 Updated by Simon Thomson about 3 years ago

  • Related to Bug #24771: Bad Signatures for EL5 Katello 3.5 client packages added

Also available in: Atom PDF