Project

General

Profile

Bug #10620

Can not pull docker images from katello once they are synced

Added by Partha Aji over 6 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1225195
Using the script at https://github.com/bkearney/soe-reference-architecture/blob/bk/container.sh I can not pull any of docker images from the satellite.

Expected result: Be able to docker pull any of the items.

Actual Result: 404 because they are protected.

Associated revisions

Revision 70dda2a5 (diff)
Added by Partha Aji over 6 years ago

Fixes #10620 - Repos no longer protected by default

Repositories created via UI are not protected by default, however this
is not the case for CLI. Repos created by the cli tend to have the
protection on by default. This does not work well for docker, so trying
to be consistent here.
Also updated code to always set protected to false for docker type. This
is because docker type does not have any protection at this time.

more

Revision 3f973656
Added by Partha Aji over 6 years ago

Merge pull request #5252 from parthaa/fix-protected

Fixes #10620 - Repos no longer protected by default

History

#1 Updated by Partha Aji over 6 years ago

  • Subject changed from Can not pull docker images from Satellite 6 once they are synced to Can not pull docker images from katello once they are synced

This mainly occurs for repositories synced via CLI since the protected attribute is automatically set to true if not specified.

Reproducer
1) hammer repository create --url=https://registry.hub.docker.com/ --docker-upstream-name=busybox --content-type=docker --product-id=1 --name=busybox
2) hammer repository info --id=1
Publish Via HTTP: yes

We need the protection to be off for docker

#2 Updated by The Foreman Bot over 6 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5252 added
  • Pull request deleted ()

#3 Updated by Partha Aji over 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#4 Updated by Eric Helms over 6 years ago

  • Assignee set to Partha Aji
  • Legacy Backlogs Release (now unused) set to 31
  • Triaged changed from No to Yes

Also available in: Atom PDF