Project

General

Profile

Bug #10666

Configured Alias interface doesn't come up automatically after host provisioning

Added by Marek Hulán almost 8 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Templates
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1225360
Description of problem:

I was trying to configure alias interface while provisioning a discovered host with rhel71. I passed eth0 mac and selected static subnet. Also checked the Virtual and Managed checkboxes.

when host was provisioned successfully, I didn't see alias interface with ifconfig -a. However configuration file of alias interface was there. and it was correctly configured. But the interface didn't come up automatically after provisioning. When I executed ifup eth0:0", interface came up with ip address.

Please note that this is the issue only on rhel71. On rhel66 I can correctly see the configured interface and it automatically come-up after provisioning.

Version-Release number of selected component (if applicable):
sat6.1 GA snap5

How reproducible:
always on rhel71

Steps to Reproduce:
1. discover a host
2. provision it with rhel71
3. add alias interface

Actual results:
Configured Alias interface doesn't come up automatically after host provisioning

Expected results:
interface should come up. no manual intervention should require.

Additional info:

Associated revisions

Revision 4adc1d68 (diff)
Added by Marek Hulán almost 8 years ago

Fixes #10666 - rename alias config files

History

#1 Updated by Marek Hulán almost 8 years ago

  • Category set to Templates
  • Status changed from New to Assigned

Confirmed on network manager IRC channel, NM ignores Alias config file if physical device does not have IPADDR parameter. Until it's fixed in upstream, one workaround is to change the config file name. Second workaround is to insert IPADDR=whatever to parent (physical) device config file. Since Alias type is deprecated we should later change the configuration snippet to configure aliases as IPADDR#{n} on parent device.

#2 Updated by Marek Hulán almost 8 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/community-templates/pull/183 added
  • Pull request deleted ()

#3 Updated by Dominic Cleal almost 8 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100
  • Legacy Backlogs Release (now unused) set to 35

Also available in: Atom PDF