Project

General

Profile

Actions

Bug #10715

closed

GET /api/v2/config_templates/build_pxe_default returns non-JSON message

Added by Tomáš Strachota about 9 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Category:
API
Target version:
Difficulty:
Triaged:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1202564
Description of problem:
GET /api/v2/config_templates/build_pxe_default returns a message that has a content-type of application/json but is not JSON.

Version-Release number of selected component (if applicable):
Tested against Satellite-6.1.0-RHEL-6-20150311.1 and Satellite-6.1.0-RHEL-7-20150311.1.

How reproducible:
Always.

Steps to Reproduce:
1. GET /api/v2/config_templates/build_pxe_default
2. Examine the response payload.

Actual results:
'PXE Default file has been deployed to all Smart Proxies'

Expected results:
The payload is valid JSON. For example, something like this:

{
'status': 'success',
'message': 'PXE Default file has been deployed to all Smart Proxies',
}

Additional info:


Related issues 1 (0 open1 closed)

Related to Foreman - Bug #6976: Build default PXE menu should be POST request instead of GETClosedTomáš Strachota08/07/2014Actions
Actions #1

Updated by Tomáš Strachota about 9 years ago

  • Category set to API
  • Status changed from New to Assigned
Actions #2

Updated by Dominic Cleal about 9 years ago

  • Related to Bug #6976: Build default PXE menu should be POST request instead of GET added
Actions #3

Updated by Dominic Cleal about 9 years ago

Linking the two bugs, because we should probably make both changes at once if we're going to change its behaviour.

Actions #4

Updated by The Foreman Bot about 9 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2439 added
  • Pull request deleted ()
Actions #5

Updated by Dominic Cleal about 9 years ago

  • Translation missing: en.field_release set to 35
Actions #6

Updated by Anonymous about 9 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100
Actions

Also available in: Atom PDF