Project

General

Profile

Bug #10790

Package groups aren't shown for add or list/remove content view package group filter rule

Added by John Mitsch over 6 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

To reproduce, navigate to content view, click on a view, then go to its filters. Click on or create a package group filter and go to add where you will not see any repositories.

Server is returning <Class> Tire::Search::SearchRequestFailed

This is happening on https://github.com/Katello/katello/blob/master/app/controllers/katello/concerns/api/v2/repository_content_controller.rb#L153

Associated revisions

Revision 45a18a0a (diff)
Added by John Mitsch over 6 years ago

Fixes #10790 - Package groups aren't listed in content view package group filter rules

Server responds with <Class> Tire::Search::SearchRequestFailed

Revision 1877e384
Added by Justin Sherrill over 6 years ago

Merge pull request #5293 from johnpmitsch/repo_index_bug

Fixes #10790 - Package groups aren't listed in content view package g…

History

#1 Updated by The Foreman Bot over 6 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5293 added
  • Pull request deleted ()

#2 Updated by John Mitsch over 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Eric Helms over 6 years ago

  • Legacy Backlogs Release (now unused) set to 31
  • Triaged changed from No to Yes

Also available in: Atom PDF