Project

General

Profile

Bug #10800

Content -> Errata : type and severity search filters are case sensitive

Added by Walden Raines almost 7 years ago. Updated almost 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1213819
Description of problem:

I have noticed that the values for the search filter are case sensitive.

Eg:
type = enhancement shows list of errata but type = Enhancement returns nothing.
severity = Critical shows list of errata but severity = critical returns nothing.

If the values are case sensitive then we should provide dropdown list for those options.

Version-Release number of selected component (if applicable):
ruby193-rubygem-katello-2.2.0.35-1.el7sat.noarch

How reproducible:
always

Steps to Reproduce:
1. go to Content -> Errata

in the search filter,
2. enter "type = enhancement" : returns list of errata
3. enter "type = Enhancement" : returns nothing

4. enter "severity = Critical" : returns list of errata
5. enter "severity = critical" : returns nothing

Actual results:
Inconsistent results across options.

Expected results:
Consistent results across options. If the values are to be case sensitive, then we should provide dropdown list for those options.

Additional info:
Issues raised by AshishH during April 15th test day

History

#1 Updated by Walden Raines almost 7 years ago

  • Status changed from New to Closed

After looking into this further I have realized this is how this search is supposed to work. The "=" operator literally means equals and not similar to. If you want to search for "Bugfix" instead of "bugfix" you need to use the "~" operator. I think that this is the expected behavior and you'd only run into this issue by purposefully capitalizing the severity or type since we have autocomplete for this search.

Note also that if you search just for "Bugfix"(i.e. without using the = operator) you will get the correct results.

#2 Updated by Eric Helms almost 7 years ago

  • Status changed from Closed to Rejected
  • Triaged changed from No to Yes

#3 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF