Project

General

Profile

Bug #10822

Can't completely delete a version of content view

Added by Partha Aji over 6 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web UI
Target version:
Difficulty:
Triaged:
Yes
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1231765
Description of problem:
Can't completely delete version of content view (with 'Completely remove version?' checkbox checked off) on WebUI, operation fails with error '404 Resource Not Found (RestClient::ResourceNotFound)'.

Version-Release number of selected component (if applicable):
Satellite 6.1.0 GA RC 2 (SNAP8-C2), RC1 (SNAP8)

How reproducible:
Always

Steps to Reproduce:
1. Log in to WebUI, create a Content View.
2. Publish new version of the content view.
3. Completely remove previously created version of CV (with 'Completely remove version?' checked off)

Actual results:
Version wasn't deleted, status of operation is 'error'. /var/log/foreman/production.log contains following error:
[E] 404 Resource Not Found (RestClient::ResourceNotFound)
Check full error log in attached cv_remove_version_error.log

Expected results:
Version was successfully deleted with no errors.

Additional info:

Associated revisions

Revision 7aa362ca (diff)
Added by David Davis over 6 years ago

Fixes #10822 - Don't clean up env content during CV remove

The problem was that both CVE delete and CVV delete were trying to delete the
same sets of repos. CVV delete was changed to delete env repos since it's used
by org destroy. However, ContentView::Remove removes all CVEs before removing
the CVV so we were getting a 404 from pulp. This adds an option CV::Remove can
use to skip deleting a CVV's env content.

Revision b4c056ec
Added by David Davis over 6 years ago

Merge pull request #5303 from daviddavis/temp/20150615142141

Fixes #10822 - Don't clean up env content during CV remove

History

#1 Updated by The Foreman Bot over 6 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5303 added
  • Pull request deleted ()

#2 Updated by David Davis over 6 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#3 Updated by Eric Helms over 6 years ago

  • Legacy Backlogs Release (now unused) set to 31
  • Triaged changed from No to Yes

Also available in: Atom PDF