Project

General

Profile

Bug #10865

starting rails in dev environment after improper shut down fails

Added by Justin Sherrill almost 7 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Orchestration
Target version:
Difficulty:
easy
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:
Red Hat JIRA:

Description

After rebooting (force rebooting) my dev vm i can no longer launch rails, i get:

/home/vagrant/git/katello/app/lib/actions/candlepin/listen_on_candlepin_events.rb:50:in `plan': Action Actions::Candlepin::ListenOnCandlepinEvents is already active (RuntimeError)
    from /home/vagrant/.rvm/gems/ruby-1.9.3-p448/gems/dynflow-0.7.8/lib/dynflow/action.rb:436:in `block (3 levels) in execute_plan'
    from /home/vagrant/.rvm/gems/ruby-1.9.3-p448/gems/dynflow-0.7.8/lib/dynflow/middleware/stack.rb:26:in `call'
    from /home/vagrant/.rvm/gems/ruby-1.9.3-p448/gems/dynflow-0.7.8/lib/dynflow/middleware/stack.rb:26:in `pass'
    from /home/vagrant/.rvm/gems/ruby-1.9.3-p448/gems/dynflow-0.7.8/lib/dynflow/middleware.rb:16:in `pass'
    from /home/vagrant/.rvm/gems/ruby-1.9.3-p448/gems/dynflow-0.7.8/lib/dynflow/middleware.rb:29:in `plan'

This could have some implications for production, but i'm unsure


Related issues

Is duplicate of foreman-tasks - Bug #8725: On unclear restart, the start occasionally fails with Action Actions::Candlepin::ListenOnCandlepinEvents is already activeClosed2014-12-16

History

#1 Updated by The Foreman Bot almost 7 years ago

  • Status changed from New to Ready For Testing
  • Pull request https://github.com/Katello/katello/pull/5313 added
  • Pull request deleted ()

#2 Updated by Ivan Necas almost 7 years ago

  • Is duplicate of Bug #8725: On unclear restart, the start occasionally fails with Action Actions::Candlepin::ListenOnCandlepinEvents is already active added

#3 Updated by Ivan Necas almost 7 years ago

  • Status changed from Ready For Testing to Duplicate

#4 Updated by Eric Helms almost 7 years ago

  • Legacy Backlogs Release (now unused) set to 31
  • Triaged changed from No to Yes

#5 Updated by Eric Helms almost 7 years ago

  • Legacy Backlogs Release (now unused) deleted (31)

#6 Updated by Eric Helms almost 6 years ago

  • Legacy Backlogs Release (now unused) set to 166

Also available in: Atom PDF