Project

General

Profile

Feature #10875

Add option to choose between MB and GB when selecting Memory for new virtual machine

Added by larry campbell about 4 years ago. Updated about 2 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Compute resources - VMware
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

during host creation, and deploying on virtual machine hypervisor (as opposed to bare metal), a new tab "Virtual Machine" is available to selection options specific for VM creation. The "Memory (MB)" option accepts an integer (presumably) that indicates the number of megabytes to give the VM. It would be a nice to have feature for an additional dropdown that allows the selection between MB and GB that the text input field would use. If MB is selected, the raw input is passed onto the VM creation job. If GB is selected, a simple multiplication of "1024 * (text field input)" would be passed to the VM.


Related issues

Related to Foreman - Bug #1580: Limitiation to create only 32 GB VMDuplicate2012-04-20
Related to Foreman - Bug #2314: Smaller grains for VM memory/RAM choice neededClosed2013-03-13

History

#1 Updated by Marek Hulán about 4 years ago

  • Subject changed from VM Creation: allow option to choose between MB and GB when selecting Memory to Add option to choose between MB and GB when selecting Memory for new virtual machine
  • Category set to Compute resources

#2 Updated by larry campbell almost 4 years ago

This looks like it may be related to request #1946

#3 Updated by Dominic Cleal over 3 years ago

  • Related to Bug #1580: Limitiation to create only 32 GB VM added

#4 Updated by Marek Hulán over 2 years ago

  • Category changed from Compute resources to Compute resources - VMware

I believe this is only true for VMware now. We should use the same spinner that we have for other compute resources. This requires the change in how we parse and send data to fog though since fog-vshpere expects megabytes.

#5 Updated by Michael Moll over 2 years ago

  • Is duplicate of Bug #2314: Smaller grains for VM memory/RAM choice needed added

#6 Updated by Michael Moll over 2 years ago

  • Is duplicate of deleted (Bug #2314: Smaller grains for VM memory/RAM choice needed)

#7 Updated by Michael Moll over 2 years ago

  • Related to Bug #2314: Smaller grains for VM memory/RAM choice needed added

#8 Updated by Michael Moll about 2 years ago

should also be resolved by #2314 now

#9 Updated by Michael Moll about 2 years ago

  • Status changed from New to Resolved

#10 Updated by Marek Hulán about 2 years ago

  • Status changed from Resolved to New

Please see comment #4, I don't think this has been implemented

Also available in: Atom PDF