Project

General

Profile

Bug #10911

Seletc2 fields do not work with nested fields

Added by Marek Hulán almost 5 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Difficulty:
Triaged:
Bugzilla link:
Fixed in Releases:
Found in Releases:

Description

There are two variants of using nested fields in Foreman, if we use add_child_link helper and the subform contains select, the select2 does not work correctly in added subform. The issue is that select2 was initialized for the template form and copying does not consider links (not sure if it's even possible). To fix this we should destroy select2 in template and reinitialize upon adding the copy of it. I think this could fix smart variable issue Shlomi has mentioned (https://github.com/theforeman/foreman/pull/2415#issuecomment-109982033) but I'm unable to verify because of #10878


Related issues

Related to Foreman - Bug #10878: Smart variables tab in puppet class detail is dysfunctionalResolved2015-06-19
Related to Foreman - Feature #10641: Ability to search VmWare networksClosed2015-05-28
Related to Foreman - Bug #14200: External user groups auth source dropdown menu doesn't openClosed2016-03-15

Associated revisions

Revision d6d3acd4 (diff)
Added by Marek Hulán almost 5 years ago

Fixes #10911 - reinitialize select2 on templated forms

History

#1 Updated by Marek Hulán almost 5 years ago

  • Related to Bug #10878: Smart variables tab in puppet class detail is dysfunctional added

#2 Updated by Marek Hulán almost 5 years ago

#3 Updated by The Foreman Bot almost 5 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2482 added
  • Pull request deleted ()

#4 Updated by Marek Hulán almost 5 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#5 Updated by Dominic Cleal about 4 years ago

  • Related to Bug #14200: External user groups auth source dropdown menu doesn't open added

Also available in: Atom PDF