Project

General

Profile

Bug #11015

PUT /api/v2/architectures/:id returns an incomplete set of attributes

Added by Alon Goldboim about 6 years ago. Updated about 6 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
API
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Cloned from https://bugzilla.redhat.com/show_bug.cgi?id=1234964
Description of problem:
An architecture has at least the following attributes:

  • id
  • name
  • organization{s,_ids}

When one updates an architecture, the following attributes are returned:

  • created_at
  • hostgroups_count
  • hosts_count
  • id
  • name
  • updated_at

The "organization" response is not mentioned in the response.

Version-Release number of selected component (if applicable):
Satellite 6.1.0. Foreman-debug is attached.

How reproducible:
100%

Steps to Reproduce:
1. Issue HTTP PUT request to https://sat.example.com/api/v2/architectures/:id
2. Capture the response. Examine the JSON payload and discover that the "organization" attribute is not mentioned.
3.

Actual results:
See "Description of problem" section.

Expected results:
See "Description of problem" section.

Additional info:


Related issues

Is duplicate of Foreman - Bug #10356: POST and PUT should use RABL templates for the response.Closed2015-05-04

History

#1 Updated by Dominic Cleal about 6 years ago

  • Is duplicate of Bug #10356: POST and PUT should use RABL templates for the response. added

#2 Updated by Dominic Cleal about 6 years ago

  • Category set to API
  • Status changed from New to Duplicate

#10356 would fix this consistently.

Also available in: Atom PDF