Project

General

Profile

Bug #11034

network/interfaces validation checks the removed interfaces

Added by Jérôme Vizcaino about 4 years ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Network
Target version:
Difficulty:
Triaged:
Bugzilla link:
Team Backlog:
Fixed in Releases:
Found in Releases:

Description

Updating the network interfaces triggers a validation to check for misconfiguration and errors.

Howto reproduce:
  • add an interface with the same mac, ip, fqdn as another interface (say eth1), name it eth2
  • remove eth1
  • submit

Validation fails, explaining that eth1 and eth2 are conflicting (but eth1 should have been removed!)

Another example: try to migrate your primary, provisioning eth0 interface as a bond0
  • add bond0 with the same mac, ip, fqdn as bond0
  • activate provision and primary for bond0
  • eth0 can now be deleted. remove eth0
  • submit

I think this is related to #11031


Related issues

Related to Foreman - Bug #11031: Cannot remove interface with duplicate nameClosed2015-07-07
Related to Foreman - Bug #11053: Ethernet interfaces not checked for uniqueness and foreman would not allow to delete.Duplicate2015-07-08
Related to Foreman - Bug #11251: Unable to save host due to 'some of the interfaces are invalid' errorResolved2015-07-29
Related to Foreman - Bug #12034: Validation of unique MAC can result in false positiveClosed2015-10-01
Related to Foreman - Bug #12486: Duplicate IP addresses after upgrading from 1.7 -> 1.8 -> 1.9Resolved2015-11-15

Associated revisions

Revision 35241dd6 (diff)
Added by Marek Hulán almost 4 years ago

Fixes #11034 - custom uniqueness validations for interface attributes

History

#1 Updated by Jérôme Vizcaino about 4 years ago

Typo, read: add bond0 with the same mac, ip, fqdn as eth0

#2 Updated by Dominic Cleal about 4 years ago

  • Related to Bug #11031: Cannot remove interface with duplicate name added

#3 Updated by Dominic Cleal about 4 years ago

  • Category set to Network

#4 Updated by Markus Frosch about 4 years ago

Got the same problem, the problem seems to be that interface to be deleted are also validated.

When you change an interface to "valid" data - like renaming eth1 to eth2 and removing the ip address, and then delete it. The deletion works

#5 Updated by Marek Hulán about 4 years ago

  • Related to Bug #11053: Ethernet interfaces not checked for uniqueness and foreman would not allow to delete. added

#6 Updated by Marek Hulán about 4 years ago

  • Related to Bug #11251: Unable to save host due to 'some of the interfaces are invalid' error added

#7 Updated by Marek Hulán almost 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Marek Hulán

#8 Updated by The Foreman Bot almost 4 years ago

  • Status changed from Assigned to Ready For Testing
  • Pull request https://github.com/theforeman/foreman/pull/2672 added
  • Pull request deleted ()

#9 Updated by Dominic Cleal almost 4 years ago

  • Legacy Backlogs Release (now unused) set to 63

#10 Updated by Marek Hulán almost 4 years ago

  • Status changed from Ready For Testing to Closed
  • % Done changed from 0 to 100

#11 Updated by Marek Hulán almost 4 years ago

  • Related to Bug #12034: Validation of unique MAC can result in false positive added

#12 Updated by Bryan Kearney almost 4 years ago

  • Bugzilla link set to 1268207

#13 Updated by Dominic Cleal over 3 years ago

  • Related to Bug #12486: Duplicate IP addresses after upgrading from 1.7 -> 1.8 -> 1.9 added

#14 Updated by Dominic Cleal over 3 years ago

If a 1.9.4 is considered, add this to the backport candidates.

Also available in: Atom PDF