Project

General

Profile

Bug #11053

Ethernet interfaces not checked for uniqueness and foreman would not allow to delete.

Added by Neeraj Harikrishnan about 6 years ago. Updated about 6 years ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
Category:
Network
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

The interface tab somehow allowed two interfaces with same name (eth0) and now would not allow to delete either one.
I get a error "Some of the interfaces are invalid. Please check the table below " when I try to delete one

Foreman Version - 1.8

Please check Screenshot attached.

Screen Shot 2015-07-08 at 11.43.49 AM.png View Screen Shot 2015-07-08 at 11.43.49 AM.png 77.1 KB Unable to delete Neeraj Harikrishnan, 07/08/2015 11:44 AM
Screen Shot 2015-07-08 at 11.46.29 AM.png View Screen Shot 2015-07-08 at 11.46.29 AM.png 82.1 KB Interfaces with same name Neeraj Harikrishnan, 07/08/2015 11:46 AM
Screen%20shot%202015 07 08%20at%2011.43.49%20am Screen%20shot%202015 07 08%20at%2011.46.29%20am

Related issues

Related to Foreman - Bug #11031: Cannot remove interface with duplicate nameClosed2015-07-07
Related to Foreman - Bug #11034: network/interfaces validation checks the removed interfaces Closed2015-07-07

History

#1 Updated by Marek Hulán about 6 years ago

  • Category set to Network
  • Status changed from New to Duplicate

I think this is duplicate of #11031

#2 Updated by Marek Hulán about 6 years ago

  • Related to Bug #11031: Cannot remove interface with duplicate name added

#3 Updated by Marek Hulán about 6 years ago

  • Related to Bug #11034: network/interfaces validation checks the removed interfaces added

Also available in: Atom PDF