Project

General

Profile

Feature #1106

puppet variable $confdir is not evaluated

Added by James Martin about 8 years ago. Updated over 7 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Difficulty:
Triaged:
No
Bugzilla link:
Pull request:
Fixed in Releases:
Found in Releases:

Description

Attempting to build a multi-environment puppet/foreman configuration. Fails during rake:

/etc/puppet.conf:

[main]
  1. The Puppet log directory.
  2. The default value is '$vardir/log'.
    logdir = /var/log/puppet
  1. Where Puppet PID files are kept.
  2. The default value is '$vardir/run'.
    rundir = /var/run/puppet
  1. Where SSL certificates are kept.
  2. The default value is '$confdir/ssl'.
    ssldir = $vardir/ssl
[agent]
  1. The file in which puppetd stores a list of the classes
  2. associated with the retrieved configuratiion. Can be loaded in
  3. the separate ``puppet`` executable using the ``--loadclasses``
  4. option.
  5. The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt
  1. Where puppetd caches the local configuration. An
  2. extension indicating the cache format is added automatically.
  3. The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig

[master]

external_nodes = /etc/puppet/external_nodes.rb
node_terminus = exec
modulepath = $confdir/environments/$environment/modules:$confdir/modules
manifest = $confdir/manifests/unknown_environment.pp

[production]
manifest = $confdir/manifests/site.pp
[dev]
manifest = $confdir/manifests/site.pp
[qa]
manifest = $confdir/manifests/site.pp

#########

rake puppet:import:puppet_classes RAILS_ENV=production
(in /usr/share/foreman)
Evaluating possible changes to your installation
Problems were detected during the evaluation phase

Unable to find directory $confdir/environments/$environment/modules in environment master

Please fix these issues and try again


Related issues

Is duplicate of Smart Proxy - Feature #1552: Puppet proxy should support $confdir in modulepath when looking for environments/classesClosed2012-03-26

History

#1 Updated by Jason Antman over 7 years ago

Sorry, but my Smart-Proxy Issue #1552 is a duplicate of this and is now closed, merged into develop. This should probably be marked as a dupe.

#2 Updated by Ohad Levy over 7 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF